Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

помогите дорешать и поправить программу на паскале решение биквадратного уравнения program bikkiv; var procedure ur(var

10-11 класс

a,b,c,x1,x2);

var

D:real

bedin

D:=b*b-4*a*c;

if D<0 then writeln('корней нет')

else D=0 then x:=-b/(2+a)

else

begin

x1:=-b-sqrt(D)/2a;

x2:=-b+sqrt(D)/2a;

end;

end;

begin

readln(a1,b1,c1,t1,t2);

ur(f1,b1,c1,t1,t2);

Pryamolineyna 06 нояб. 2016 г., 18:55:31 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Дима4
06 нояб. 2016 г., 19:53:51 (7 лет назад)

var a,b,c,y1,y2,d,i:real;
begin
read(a,b,c);
d:=b*b-4*a*c;
if d>0 then
begin
y1:=(-1*b+sqrt(d))/(2*a);
y2:=(-1*b-sqrt(d))/(2*a);
if y1>=0 then 
begin   
writeln(sqrt(y1));   
writeln(sqrt(y1)*-1); 
end; 
if y2>=0 then  begin   
writeln(sqrt(y2));   
writeln(sqrt(y2)*-1); 
end;
end else
if d=0 then
begin
y1:=(-1*b)/(2*a);
if y1>=0 then  begin   
writeln(sqrt(y1));   
writeln(sqrt(y1)*-1); 
end; 
end
else
writeln('Корней нет');
end.

+ 0 -
Rfnz44
06 нояб. 2016 г., 21:29:58 (7 лет назад)

я сам напишу,ок?

Ответить

Другие вопросы из категории

как называется поименованная информация на диске

1) дисковод 2)папка 3)файл
4)каталог

Помогите с решением !
Предположим, что машинистка может непрерывно день за днем печатать текст со скоростью 60 слов в минуту. Сколько времени потребуется ей, чтобы заполнить

компакт-диск емкостью 640 Мбайт? Будем считать, что каждое слово состоит из пяти букв, а для сохранения каждой буквы требуется 2 байт.

Читайте также

Помогите исправить ошибки Задание: составить программу на яз. Паскаль с использованием цикла с неизвестным числом повторений для вычислений значения

функции F(x)=sin(x)+tg(x) на отрезке [А, В] при изменении аргумента в точках хi = А+iН, где Н – шаг. А=1, В=2, Н=0,125.

Листинг программы:

Program Tabulir;

Var x, y: real;

Begin x:=1;

While x≤2 do begin

y:=sin(x)+tg(x);

writeln (x:9:1, y:16:3);

x:=x+0,125;

End.

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Помогите создать программу на паскаль:

Разработать
программу в соответствии со своим вариантом: создать структуру типа «запись», выполнить
обработку данных.



Вы находитесь на странице вопроса "помогите дорешать и поправить программу на паскале решение биквадратного уравнения program bikkiv; var procedure ur(var", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.