Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 10% предоставляется, если сумма покупкибольше 1000 рублей

10-11 класс

Малинкина 26 авг. 2014 г., 12:17:03 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vfvf2001vfif
26 авг. 2014 г., 14:44:52 (9 лет назад)

var

  n, s : longint;

begin

  write ('Введите рубли');

  read (n);

  s := n * 100;

  write ('Введите копейки');

  read (n);

  s := s + n;

  if s > 100000 then s := s - s div 10;

  writeln (s div 100, ' рублей, ', s mod 100, ' копеек.');

end.

Ответить

Другие вопросы из категории

Pascal ABC написать программу
Сделайте пожалуйста блок-схему или код в small basic. Дан массив из 20 целых чисел. В массиве хранятся результаты соревнований по спортивной стрельбе.

Один элемент массива соответствует количеству очков, набранных одним участником соревнований, и имеет значение от 0 до 30 включительно. Необходимо разработать программу, которая по данным массива вычисляет максимальное количество очков среди участников соревнований, и количество участников набравшее зачётное количество очков. Зачётное количество очков 18. Гарантируется, что хотя бы один участник соревнований набрал зачётное количество очков.

пожалуйста помогите и пишите понятно!!!!

1 задания: перевидите числа в десятичную систему счисления
а) 10101011 в степени 2
б) 1011,101 в степени 2
2 задания: переведите число 1011001011110010 в степени 2
а) в восьмеричную систему счисления
б) в 16-ричную систему счисления
3 задания:выполнить действия
а) 10110,11 в степени 2 + 1101,01 в степени 2
б) 101 в степени 2 умножить 111 в степени 2!

Читайте также

Написать программу вычисления стоимости некоторого количества (по весу) яблок.

Ниже приведен рекомендуемый вид экрана во время выполнения программы (данные,
введенные пользователем, выделены полужирным шрифтом).
Вычисление стоимости покупки.
Введите исходные данные:
Цена
одного килограмма яблок (руб.) -> 8.5
Вес яблок (кг) ->
2.3
Стоимость покупки: 19.55 руб.

Написать программу вычисления стоимости некоторого количества (по весу) яблок. Ниже приведен рекомендуемый вид экрана во время выполнения программы

(данные, введенные пользователем, выделены полужирным шрифтом).

Вычисление стоимости покупки.
Введите исходные данные:
Цена одного килограмма яблок (руб.) -> 8.5
Вес яблок (кг) -> 2.3
Стоимость покупки: 19.55 руб.



Вы находитесь на странице вопроса "Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 10% предоставляется, если сумма покупкибольше 1000 рублей", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.