Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

дан одномерный массив {Ai}, состоящий из n элементов. Вычислить среднее арифметическое значение этих элементов

10-11 класс

Lina123456677 04 дек. 2016 г., 22:33:22 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lera1234567890000
04 дек. 2016 г., 23:31:38 (7 лет назад)

Uses crt;
Var m:array[1..1000] of integer;
I,sr,n:integer;
Begin
Clrscr;
Writeln('Введите размер массива');
Readln(n);
For i:=1 to n do
Begin
m[i]:=random(30)+1;
Write(m[i],' ');
Sr:=sr+m[i];
End;
Writeln;
Writeln(' Сред. Арф. = ',sr div n);
Readkey;
End.

Ответить

Другие вопросы из категории

Помогите решить , пожалуйста
Четыре друга – Андреев, Васин, Сомов, Дымов – решили провести свой отпуск в четырех различных городах – Москве, Петербурге, Киеве и Ташкенте. В какой

город должен поехать каждый из них, если известно: Если Андреев не едет в Москву, то Сомов не едет в Петербург; Если Васин не едет ни в Москву, ни в Ташкент, то Андреев едет в Москву; Если Сомов не едет в Ташкент, то Васин едет в Киев; Если Дымов не едет в Москву, то Васин едет в Москву; Если Дымов не едет в Петербург, то Васин не едет в Москву.

Слова связанные с информатикой
У робота-исполнителя две команды, которым присвоены номера:

1. прибавь 1.
2. умножь на 2.
Робот либо прибавляет к числу на экране 1, либо удваивает его. Какая последовательность сделает из 1 число 8?

Читайте также

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного

числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ ПОЖАЛУЙСТА.я пропустила тему.ПО ПАСКАЛЬ.!!

Дан одномерный массив А состоящий из 10 элементов.Вывести на экран исходную таблицу и резултат программы.
Найти произведения элементов массива А. удовлетворяющих условию:
c<=A[i]<=d.

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

Дан одномерный

целочисленный массив А, состоящий из
N элементов,
N -
заданное натуральное число. Упорядочить элементы массива
по неубыванию. (программа +блок-схема)на языке QBasic



Вы находитесь на странице вопроса "дан одномерный массив {Ai}, состоящий из n элементов. Вычислить среднее арифметическое значение этих элементов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.