Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дана последовательность целых чисел, заканчиваемые нулем. Подсчитайте сумму положительных чисел последовательности. Пожалуйста помоги!!!

5-9 класс

Mahdi06ingame 28 июля 2013 г., 2:44:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Suliman959
28 июля 2013 г., 5:05:24 (10 лет назад)

program beg;
var a,sum:integer;
begin
a:=-1;
while a<>0 do
begin
read(a);
if a>0 then sum:=sum+a;
end;
writeln(sum);
end.

Ответить

Другие вопросы из категории

1. Квадрат трехзначного числа оканчивается тремя цифрами, которые как раз и составляют это число. Найти такие числа (например, 625: 625^2=390 625).

2. Найти сумму целых положительных чисел, больших 20, меньших 100, кратных 3 и заканчивающихся на 2,4 или 8.

Решить в Паскале

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

Дана непустая последовательность целых чисел, оканчивающаяся нулем

(0 является признаком окончания последовательности и в последовательность не входит).
Найти и напечатать:
1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Если таких чисел нет, то напечатать «Таких чисел нет»
2. Количество четных чисел



Вы находитесь на странице вопроса "Дана последовательность целых чисел, заканчиваемые нулем. Подсчитайте сумму положительных чисел последовательности. Пожалуйста помоги!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.