Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Сколько существует

10-11 класс

(невырожденных) треугольников периметра N с целыми длинами сторон? (Треугольник со сторонами a,b,c называется невырожденным, если из отрезков длины a,b,c его можно составить.)
Входные данные, С клавиатуры вводится число N (1 \leq N \leq 1000)/
Выходные данные, Программа выводит число таких треугольников.

Lsonc5555631156887 05 февр. 2017 г., 1:51:58 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
НстяКекс
05 февр. 2017 г., 3:47:55 (7 лет назад)

var k, n,a,b,c:integer;
Begin
  read(n);
 
  for a := 1 to n do begin
    for b := a to n - a do begin
      c := n - a - b;
      if (c>=a) and (c>=b) and (c>0) and (a+b>c) and (a+c>b) and (b+c>a) then
        k := k + 1;
    end;
  end;
  writeln(k);
End.

Ответить

Другие вопросы из категории

Какие двоичные, восьмеричные и шестнадцатеричные числа соответствуют данным десятичным: 128,256,512,1024,2,7,17,68,315,765,2047.

Чему в десятичной, восьмеричной и шестнадцатеричной системе равны следующие двоичные числа : 1000001, 101, 11101, 101010, 100011, 10110111011, 10000001, 100000001

Переведи в десятичную CC
75(8); B4(16); 213(5); 613(8); 16(16); 14(9); AFC10(16); 10765(8); F026(16)

В матрице найти сумму элементов четных столбцов. Если эта сумма положительна, то все элементы нечетных строк возвести в квадрат. В противном случае ко

всем элементам побочной диагонали прибавить число 2. Помогите с решением, в прошлый раз была ошибка надо найти именно сумму элементов четных столбцов.

Читайте также

Запись

некоторого натурального числа X в шестнадцатеричной системе счисления имеет
ровно три значащих разряда. Это число увеличили в два раза, и оказалось, что
запись получившегося числа Y в шестнадцатеричной системе также имеет ровно три
значащих разряда, причем сумма цифр шестнадцатеричной записи исходного числа X
равна сумме цифр шестнадцатеричной записи полученного числа Y. Сколько
существует таких чисел X, которые удовлетворяют указанным условиям и при этом
содержат хотя бы одну цифру 2 в своей шестнадцатеричной записи? В ответе
укажите целое число.
Нужно составить программу, которая автоматически переберет все числа от 100 до FFF

решение - объяснение Сколько существует различных пар натуральных чисел, таких что: Ваш ответ: 86 1. Оба числа, записанные в

шестеричной системе счисления, имеют ровно по три значащих разряда. 2. Сумма этих чисел, записанная в шестеричной системе счисления, содержит только цифры «1». Пары чисел, отличающиеся только порядком следования чисел в паре, считаются одинаковыми. В ответе укажите целое число.

Задача:

Сколько существует различных последовательностей из символов «плюс» и «минус», длиной ровно в пять символов?

10-11 класс информатика ответов нет
Сколько существует различных наборов значений логических переменныхx1, x2, x3, x4, y1, y2 y3, y4, которые удовлетворяют всем перечисленным

нижеусловиям?(x1 → x2) /\ (x2 → x3) /\ (x3 → x4) = 1(¬y1 \/ y2) /\ (¬y2 \/ y3) /\ (¬y3 \/ y4) = 1(y1 → x1) /\ (y2 → x2) /\ (y3 → x3) /\ (y4 → x4) = 1



Вы находитесь на странице вопроса "Сколько существует", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.