Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Запись

10-11 класс

некоторого натурального числа X в шестнадцатеричной системе счисления имеет
ровно три значащих разряда. Это число увеличили в два раза, и оказалось, что
запись получившегося числа Y в шестнадцатеричной системе также имеет ровно три
значащих разряда, причем сумма цифр шестнадцатеричной записи исходного числа X
равна сумме цифр шестнадцатеричной записи полученного числа Y. Сколько
существует таких чисел X, которые удовлетворяют указанным условиям и при этом
содержат хотя бы одну цифру 2 в своей шестнадцатеричной записи? В ответе
укажите целое число.
Нужно составить программу, которая автоматически переберет все числа от 100 до FFF

NemnogoUmnii 13 марта 2014 г., 8:03:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MadNigga
13 марта 2014 г., 10:32:00 (10 лет назад)

Последнее проверяемое число 7FF, поскольку большее число при удвоении будет четырехзначным, нарушая условие задания.

procedure Analyze(n: integer; var sd: integer; var has2: boolean);
{Для заданного целого n возвращает:
  sd - сумму цифр в шестнадцатиричном представлении;
  has2 - true, если среди шестнадцитиричных цифр имеется хотя бы одна двойка.}
const
  mask = $00F;

var
  i, r: integer;

begin
  has2 := false;
  sd := 0;
  for i := 1 to 3 do
  begin
    r := (n and mask);
    has2 := (has2 or (r = 2));
    sd := sd + r;
    n := (n shr 4);
  end
end;

function IsSuitable(n: integer): Boolean;
{Проверяет, удовлетворяет ли число n набору условий}

var
  s1, s2: integer;
  has2, stub: boolean;

begin
  Analyze(n, s1, has2);
  Analyze(2 * n, s2, stub);
  IsSuitable := ((s1 = s2) and has2)
end;


var
  i, n: integer;

begin
  n := 0;
  for i := $100 to $7FF do
    if IsSuitable(i) then n := n + 1;
  Writeln('Найдено чисел- ', n)
end.

Результат выполнения программы:
Найдено чисел- 23


Ответить

Читайте также

иван 10 секунд записывал двухканальную стерео запись с частотой дискретизации 16 Кгц и глубиной кодирования 24 бита. затем он 10 секунд записывал с такими

же характеристиками одноканальную моно запись. найдите общий объем получившихся двух файлов.

Двоичная запись десятичного числа: 1) 255 2) 497 3) 513 4) 127 5) 1030 ? Укажите число, двоичная

запись которого содержит ровно

6) 2 единицы (14, 31, 18, 16)

7) 3 единицы (12, 10, 8, 14)

8) 4 единицы (35, 15, 21, 32)

и в файле ещё надо)

Помогите пожалуйста! Задание: 1) Укажите через запятую в порядке возрастания все десятичные числа, не превосходящие 25, запись которых в

троичной системе счисления оканчивается на 21?

2) укажите через запятую в порядке возрастания все десятичные числа, не превосходящие 45, запись кторых в двоичной системе счисления оканчивается на 1010?

3) Укажите сколько всего раз встретится цифра 3 в записи чисел 13, 14,15,...,23 в системе счисления с основанием 4?

№1. Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись числа 11 оканчивается на 1. №2.

Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись числа 19 оканчивается на 4.

№3. Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись числа 27 оканчивается на 3.

100 пкт. Запись числа 281 в системе счисления с основанием n содержит 3 цифры и оканчивается на 1. чему равно максимально возможное основание системы

счисления.
Запись натурального числа в системах счисления с основанием 3 и 5 заканчивается на 0. найдите миним. натуральное число, удовлетворяющее этим условиям



Вы находитесь на странице вопроса "Запись", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.