Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дано целое число.Если оно является положительным,то прибавить к нему 1,в противоположном случае вычесть из него 2.Вывести полученное число.

1-4 класс

Rock123 19 сент. 2016 г., 5:26:36 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
TANYA2000O
19 сент. 2016 г., 6:28:08 (7 лет назад)

var a: integer;
begin
read(a);
if a>=0 then a:= a+1
else a:= a-2;
write(a);
end.

+ 0 -
ЭлькаЭ
19 сент. 2016 г., 8:31:30 (7 лет назад)

var a :longint;
begin
readln(a);
If a>0 then a:=a+1 else a:=a-2;
writeln(a);
end.

+ 0 -
Lyudmilaolshans
19 сент. 2016 г., 9:17:53 (7 лет назад)

Надо прогу написать ?

+ 0 -
Kamakama2003kama
19 сент. 2016 г., 9:57:10 (7 лет назад)

да

Ответить

Другие вопросы из категории

Сколько битов в байте
Что такое информация?
Плиииз помогите завтра уже сдавать.

Продолжите фразы:
а) Информация - это ................................................
б) Действия с информацией - это действие, связанные с...................................................
СРОЧНО. ПРОШУУУУУУ

Читайте также

Даны два целых числа - координаты точки в декартовой системе координат. Определить, в какой четверти находится точка.

Входные данные:
Во входном потоке заданы два целых ненулевых числа, значение которых по модулю не превышают 30000.

Выходные данные:
В выходной потов вывести единственное целое число.

Пример входного файла
3 9

PascalABC 1. Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в

интервале между двумя введёнными числами. Например, пользователь вводит числа 10 и 20, программа выводит «12 14 16 18», если -8 и -3, то «-6 –4». Если пользователь вводит, например, числа 6 и 8, программа ничего не выводит. Точно так же программа ничего не выводит, если введённые числа равны, или второе указанное число меньше первого.

Дано целое число i.

найти значение a,
где a=i^3, если i кратно 5
a=i^2, если i кратно 2.
a=2*i+1 в остальных случаях.

Даны действительные числа x,y,z Если все числа положительны, увеличить их значения в 2 раза;во всех отальных случаях отрицательные числа заменить их

модулями, а положительные оставить без изменения.(Надо написать программу на паскале)



Вы находитесь на странице вопроса "Дано целое число.Если оно является положительным,то прибавить к нему 1,в противоположном случае вычесть из него 2.Вывести полученное число.", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.