Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Задача: Факториал числа представляет собой произведение всех натуральных чисел от 1 до этого числа включительно.

10-11 класс

Например, факториал числа 7 выглядит так:
1 * 2 * 3 * 4 * 5 * 6 * 7

Kvladimir1997 03 июня 2014 г., 15:01:27 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Murzik24
03 июня 2014 г., 17:26:04 (9 лет назад)

uses crt;var f:real;
    x,n:integer;
begin
     f:=1;
     write('N='); readln(N);
     if N<0 then writeln('EROOR!') else
     if N=0 then writeln('N!=',1)

+ 0 -
пофигисты
03 июня 2014 г., 18:25:58 (9 лет назад)

1)readln(n);
if (n=0) then writeln('0!=1') else
if (n<0) then writeln('Определяется только для положительных чисел') else
begin
s:=1;
for i:=1 to n do
s:=s*i;
writeln(n,'!='s:0:0);
end;

2)function f(x:byte):real;
begin
if x=0 then f:=1
else f:=f(x-1)*x;
end;2
с помощью рекурсии, как видно

+ 0 -
алеся2015
03 июня 2014 г., 19:34:12 (9 лет назад)

Полагаю, что вопрос о больших числах?

+ 0 -
милотааа
03 июня 2014 г., 21:58:19 (9 лет назад)

он сам не знает, чего хочет

+ 0 -
клео8
03 июня 2014 г., 23:26:06 (9 лет назад)

числа идут о неимоверно больших числах

+ 0 -
Tolibov14
04 июня 2014 г., 0:19:34 (9 лет назад)

где нудно пользоваться строками

+ 0 -
Linochka88983476
04 июня 2014 г., 1:46:17 (9 лет назад)

нужно*

Ответить

Другие вопросы из категории

нужно составить логическую формулу, используя СДНФ или СКНФ. упростить полученную логическую формулу до минимального кол-ва используемых лог. операций и

(если уто сможет) постороить логическую схему для формулы, которую упростил ...будьте добры, помогите вот таблица истинности : АВСF
0000
0010
0100
0111
1001
1010
1101
1110
фотографию загрузить не получилось... (

Нужно решение примера 6519,325

Читайте также

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

1)Написать программу вывода всех четных чисел от 2 до 1000 включительно

2)Написать программу определяющую сумму всех нечетных чисел от 1 до 99

. Даны два целых числа A и B

(A < B). Найти произведение всех целых чисел от A до B
включительно.

1.пользователь вводит натуральное число. Определить среднее арифметическое цифр этого числа.

2.пользователь вводит натуральное число N. Найти сумму всех натуральных чисел от 1 до N.



Вы находитесь на странице вопроса "Задача: Факториал числа представляет собой произведение всех натуральных чисел от 1 до этого числа включительно.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.