Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста исправить ошибку "неверная вещественная операция (7.PAS, строка 9)" уже не знаю как исправить задание: для

10-11 класс

натурального n и действительного x подсчитать сумму S=-1/2 + 1/2^2 - 1/2^3 +...+(-1)^n / 2^n

program summa;
uses crt;
var n,i:integer; s:real;
begin clrscr;
writeln ('vvedite n');
readln (n);
s:=0;
for i:=1 to n do
s:=s+exp(ln(-1)*i)/exp(ln(2)*i);
writeln ('s=', s);
readln
end.

Ols03 05 янв. 2017 г., 2:54:27 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
InnaMalina
05 янв. 2017 г., 5:12:19 (7 лет назад)

ошибка в том что натуральный логарифм (-1) не существует

 

program summa;

Ответить

Другие вопросы из категории

1. Алгоритм разветвления.

Составить алгоритм вывода на
экран меньшего из двух данных чисел.




Читайте также

Помогите пожалуйста исправить ошибку "неверная вещественная операция (7.PAS, строка 9)" уже не знаю как исправить задание: для

натурального n и действительного x подсчитать сумму S=-1/2 + 1/2^2 - 1/2^3 +...+(-1)^n / 2^n

program summa;
uses crt;
var n,i:integer; s:real;
begin clrscr;
writeln ('vvedite n');
readln (n);
s:=0;
for i:=1 to n do
s:=s+exp(ln(-1)*i)/exp(ln(2)*i);
writeln ('s=', s);
readln
end.

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)



Вы находитесь на странице вопроса "Помогите пожалуйста исправить ошибку "неверная вещественная операция (7.PAS, строка 9)" уже не знаю как исправить задание: для", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.