Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Исполните следующий фрагмент линейного алгоритма для а=х и b=у.

5-9 класс

а:=a+b

b:=b-a

a:=a+b

b:=-b
Какие значения присвоены переменным а и b?
а)у,х

б)х+у,х-у

в)х,у

г)-у,х

Murkaaa 31 мая 2013 г., 19:59:27 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mirnag
31 мая 2013 г., 22:43:54 (10 лет назад)

правильный ответ А,решается путем подстановки переменных друг в друга

+ 0 -
NISPVL
01 июня 2013 г., 0:46:29 (10 лет назад)

a=x ; b=y

a=a+b

подставляем

отсюда имеем a=x+y

теперь подставиляем в b=b-a 

отсюда имеем b=y-x

a= x+y+y-x

если b=y-x, то:  -b= -(у-x)=-y+x или x-y

ответ: б

 

у меня у самой это в тесте было, у меня ответ б и это правильный ответ)

Ответить

Другие вопросы из категории

Пожалуйста помогите!

какое значение переменной будет S?
Var
s,k:integer;
Begin
s:=0;
for k:= 6 to 12 do
s:=s+10;
writeln(s);
End.

Составьте алгоритм!)

Читайте также

1)Дан фрагмент линейного алгоритма.

а:=8

b:=6+3*а

а:=b/3*а

Чему равно значение переменной а после его исполнения?


Ваш ответ:

2)Исполните следующий фрагмент линейного алгоритм для а = х и b = y.

а:=а+b

b:=b-a

а:=а+b

b:=-b

Какие значения присвоены переменным a и b?

а)-у, х
б)y, х
в)х, у
г)х+у, х-у

3)Определите значение целочисленных переменных х и у после выполнения фрагмента программы.

х:=11

у:=5

t:=y

у:=х mod у

x:=t

y:=y+2*t

а)х = 10, у = 5
б)х = 5, у = 11
в)x = 11, y = 5
г)х = 5, у = 10

4)Среди четырёх монет есть одна фальшивая. Неизвестно, легче она или тяжелее настоящей. Какое минимальное количество взвешиваний необходимо сделать на весах с двумя чашками без гирь, чтобы определить фальшивую монету?

а)4
б)2
в)5
с)3

НАПИШИТЕ ПОЖАЛУЙСТА ПРОГРАММУ ДЛЯ ПАСКАЛЯ: 1) Разработайте алгоритм для ввода в память ЭВМ линейной таблицы В, состоящей из 8 элементов вещественного

типа. Ввод организуйе без использования цикла 2) разработайте алгоритм для ввода в память ЭВМ одномерного массива С состоященр из 7 элементов целого тип. Ввод организуйе с исползованием цикла "ДЛЯ". 3) разработайте алгоритм для ввода в память ЭВМ одномерного массива Д состоящего из 10 элементов целого типа. Каждый элемнт вычислите по формуле: значение элемента равно квадрату его индекса

Подробности от учителя:1.Определить значение переменной у после выполнения следующего фрагмента программы:

y:=1;
For i:=2 to 4 do y:=y+i;

2.Определить значение переменной у после выполнения следующего фрагмента программы:
y:=0;
For i:=-100 to 100 do
If i mod 10 =5 then y:=y+i;

3. На промежутке [a;b] (a,b -целые числа, которые вводятся с клавиатуры) определить среднее арифметическое чисел кратных 7



Вы находитесь на странице вопроса "Исполните следующий фрагмент линейного алгоритма для а=х и b=у.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.