Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

написать программу которая напечатает 2-х мерный массив 4*4 из целых сл.чисел от -12 до +12.Элементы в нечётных строках перемножить и сообщить это произ

5-9 класс

ведение в паскале авс

Hyhyhyhyhyhyhyh 27 нояб. 2013 г., 21:38:05 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Poit65
27 нояб. 2013 г., 23:35:09 (10 лет назад)

Program asd;
USES crt;
Const n=4;
var  A:array [1..n, 1..n] of integer;
i,j,s:integer;
BEGIN
clrscr;
Writeln('Massiv 4x4: ');
for i:=1 to n do 
begin 
for j:=1 to n do 
  begin 
 A[i,j]:=random(12)-6;   
Write(' ',A[i,j]:2);
    end; 
     Writeln; 
   end;
    Writeln('Otvet: ');
    For i:=1 to n do 
   begin     
 for j:=1 to n do   
   begin     
    S:=A[i,j];   
    if A[i,j]<0 then 
      S:=A[i,j]*S;     
   Write(' ',S:2)       
 end;     
  Writeln;     
  end;
END.

+ 0 -
EREMKINA82
28 нояб. 2013 г., 2:09:41 (10 лет назад)

Хорошая задача, сейчас посмотрим

Ответить

Другие вопросы из категории

Помогите решить

1. Для записи текста использовался 64-символьный алфавит. Какой объем информации в килобайтах содержат 10 страниц текста, если на каждой странице расположено 32 строки по 64 символа в строке?
2. Определи количество информации в книге, набранной на компьютере. Книга содержит 2048 страниц. На каждой странице - 32 строки, в каждой строке - 64 символа. Запиши ответ в наиболее подходящих единицах.

где можно пробить ИС-7

Читайте также

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

Паскаль абс 2 задачи 1)Написать программу выводящую на экран последовательность чисел от 1 до 10 через пробел в строчку.

2)Написать программу которая бы выводила на экран произведение нечетных чисел от 10 до 20.

1)Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.

2)Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n



Вы находитесь на странице вопроса "написать программу которая напечатает 2-х мерный массив 4*4 из целых сл.чисел от -12 до +12.Элементы в нечётных строках перемножить и сообщить это произ", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.