Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите пожалуйста! вообщем задачи надо составить по паскалю

5-9 класс

1. Дан массив состоящий из 12 случайных целых чисел от -5 до 12. Все его элементы умножить на последний элемент.

2.Дан массив состоящий их 7 вещественных чисел. Из всех положительных элементов массива вычесть элемент с номером k, из всех отрицательных n ( числа k и n вводятся с клавиатуры). Нулевые элементы оставить без изменения.

3. В массиве хранится информация о росте 25 челловек. Определить, на сколько рост самого высокого человека превышает рост самого низкого.

4. Дан массив целых чисел. Найти номер первого четного элемента массива (массив просматривайте с конца, используя цикл for...downto). Если четных елементов нет. то должно быть напечатано соответствующее сообщение.

Vvv98 16 марта 2017 г., 10:38:05 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
копов
16 марта 2017 г., 13:33:53 (7 лет назад)

1)
var a: array[1..12] of integer;
begin
  for i:=1 to 12 do read(a[i]);
  for i:=1 to 12 do write(a[i]*a[12], ' ');
end.

Ответить

Читайте также

Помогите, пожалуйста, с задачами в программе "Паскаль"! ОЧЕНЬ НАДООООО!!!!

Задание во вложении, необходимо решить задачи с 3 по 5

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!



Вы находитесь на странице вопроса "помогите пожалуйста! вообщем задачи надо составить по паскалю", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.