Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

найти ближайшую к a степень тройки(паскаль)

1-4 класс

Krisssf 20 июля 2013 г., 14:06:47 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
удивленная
20 июля 2013 г., 15:20:23 (10 лет назад)

var a, stepen1, stepen2: longint;

begin
clrscr;
readln(a);
stepen1:=1;
while stepen1<= a do
 stepen1:=stepen1*3;
stepen2:=stepen div 3;
if (a-stepen2) >= (stepen1-a) then writeln(stepen1)
 else
 writeln(stepen2);
end.

+ 0 -
Nasekinro2014
20 июля 2013 г., 15:58:19 (10 лет назад)

))

+ 0 -
Gtytt
20 июля 2013 г., 17:08:35 (10 лет назад)

ты какой класс ??

+ 0 -
Сонечка55
20 июля 2013 г., 19:30:20 (10 лет назад)

или школу закончил ?))

+ 0 -
Rraaa
20 июля 2013 г., 20:57:37 (10 лет назад)

clrscr;longint; Что это за команды ?

+ 0 -
Christina17
20 июля 2013 г., 23:19:12 (10 лет назад)

clrscr - можеш убрать, это отчиска экран, лонгинт можно засенить на integer

Ответить

Другие вопросы из категории

Вставь пропущенные слова :

Электронный__________ - это набор данных , которые хранятся в ___________ компьютера под определённым _____________.

Данные для справки : данные , документ , свойства , имя , объект , компьютер .

в солнечный город пришла фея......

Читайте также

Хитрая Кикимора решила в отсутствие Змея Горыныча разыскать спрятанный им клад. Для этого Кикимора должна за 3 дня успеть найти владения Змея Горыныча

и обследовать 4 пещеры. За первый день она может найти владения Змея Горыныча, за второй день она сможет обследовать первую или вторую пещеру. Нарисуйте «Дерево решений» и найдите, сколько разных вариантов есть у Кикиморы, чтобы найти владения Змея Горыныча и обследовать пещеры, если за третий день она сможет обследовать только одну пещеру из оставшихся. Успеет ли Кикимора обследовать все пещеры за 3 дня?

Найти максимальный элемент массива X(10).

помогите написать программу в паскале пожалуйста.

Паскаль

Решить задачи.
1. Дано трёхзначное число. Определить, сколько раз в нём встречается цифра 3.
2. Дано натуральное число. Получить все его делители и найти их сумму.



Вы находитесь на странице вопроса "найти ближайшую к a степень тройки(паскаль)", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.