Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1. Дан файл целых чисел. Преобразовать его, удалив

10-11 класс

нечетные числа. Порядок следования четных чисел сохранить.Решите пожалуйста !

Rakiwevaaltyna 24 апр. 2014 г., 18:00:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Fjsjtxbfh
24 апр. 2014 г., 20:59:39 (10 лет назад)

var
  f: file of integer;
  i2, i, n: integer;

begin
  Assign(f, 'numbers.txt');
  Reset(f);
  writeln;
  i:=1;
  i2:=0;
  while not Eof(f) do
    begin
    read(f, n);
    i:=i+1;
    if n mod 2=0 then
      begin
      i2:=i2+1;
      if i2<i then
        begin
        Seek(f,i2-1);
        write(f,n);
        Seek(f,i-1)
        end
      end
    end;
  Seek(f,i2);
  Truncate(f);
  close(f)
end.

Внимание!!! Файл не является текстовым!!!

+ 0 -
Lenarjirf
24 апр. 2014 г., 22:31:49 (10 лет назад)

Комментарий удален

+ 0 -
Nikita123452
24 апр. 2014 г., 23:37:12 (10 лет назад)

Комментарий удален

+ 0 -
Fn8728
25 апр. 2014 г., 0:32:25 (10 лет назад)

Преподаватель вкурсе

+ 0 -
LUDATHERVINSKA
25 апр. 2014 г., 3:28:42 (10 лет назад)

Главное что бы код программы был правильный

+ 0 -
Шмуксик
25 апр. 2014 г., 4:27:48 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Помогите сделать!

Составить таблицу истинности логической
функции:




Помогите!!!

Кто создал первый в мире ПК ?

Читайте также

Задачи на записи и файлы. № 1. Пусть дан файл целых чисел. Определите длину наибольшего интервала возрастания и среднее арифметическое чисел этого

интервала. № 2. Имеется типизированный файл с числами. Изменить все его элементы, порядковый номер которых кратен трем. Новые значения вводятся с клавиатуры. Размер существующего файла неизвестен.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

Решение задач с использованием файлов

1. Дано число к и файл, содержащий целые числа. Вывести элемент файла с номером к. если такой элемент отсутствует, то вывести 0.

2. Дан файл вещественных чисел. Создать 2 новых файла, в первый из которых содержит строки исходного файла с четными номерами, а второй с нечетными номерами.



Вы находитесь на странице вопроса "1. Дан файл целых чисел. Преобразовать его, удалив", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.