Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Сделать одномерный массив.

10-11 класс

В массив A[N] занесены натуральные числа. Найти сумму тех элементов, каторые кратны данному значению К. Элементы массива вводить с клавиатуры.

856312908 28 авг. 2016 г., 3:39:05 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alex123Alex
28 авг. 2016 г., 6:22:55 (7 лет назад)

Var i, k, n, sum: Integer;
    a: Array[1..1000000] of Integer;
begin
  ReadLn(n, k);
  for i:=1 to n do a[i]:=i;
  sum:=0;
  for i:=1 to n do
    if a[i] mod k = 0 then
      sum:=sum+a[i];
  WriteLn(sum);
end.

Ответить

Другие вопросы из категории

Составьте программу, которая для числа K (от 1 до 99), введенного вами, напечатает фразу «Мне K лет», где K – введенное число, при этом в нужных случаях

слово «лет» заменяя на «год» или «года». Например, при K=70 «Мне 70 лет», при K=15 «Мне 15 лет», при K=23 «Мне 23 года», при K=31 «Мне 31 год».
что значит until и case в этой задаче

нужно создать программу на языке програмирования паскаль, чтобы вводить сведения о авто ( вводить марку) а программа выдавала сведения о ее хозяине (

программа выдает номер авто и фамилию хозяина)

задача:
Сведения об автомобиле состоят из его марки, номера и фамилии владельца. Дана файл f , содержащий сведения о нескольких автомобилях. Найти фамилии влвдельцев и номера автомобилей по данной марки

Разработать программу для расчёта площади

поверхности и объёма шара известного радиуса.

Читайте также

определить число элементов массива, больших К. По заданному условию сформировать одномерный массив, вывести на печать и произвести операции по обрабо

тке полученных компонентов массива. Исходными данными являются одномерный массив, элементы которого задаются с помощью датчика случайных чисел от -50 до +50 и целое положительное число К

Используя матрицу размером 4х4 с картинки, максим создал одномерный массив размером 16 и заполнил его по следующему принципу. Двигаясь в матрице по

спирали в очередной элемент одномерного массива ( начиная с первого) он записывал элемент матрицы с нечетной суммой индексов. Затем, двигаясь в обратном направлении по этой же спирали, последовательно записывал в одномерный массив элементы матрицы с четной суммой индексов. Сколько четных элементов одновременно массива стоят на нечетных местах?
А) 8 Б) 2 В) 16 Г) 4
1 2 3 4
8 7 6 5|
9 10 11 12
16 15 14 13

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.



Вы находитесь на странице вопроса "Сделать одномерный массив.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.