Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогиииитееее!!!!

10-11 класс

на паскале
1.Найти сумму первых 10 натуральных нечетных чисел.
2.Найти произведение натуральных чисел прекратить подсчет при вводе 1.

Alinamadykina 23 февр. 2014 г., 14:35:31 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
HarulaLis72
23 февр. 2014 г., 15:32:52 (10 лет назад)

var
a,b,c,d:integer;
begin
c:=1;
b:=0;
while a<>1 do begin
readln(a);
if a mod 2 <> 0 then begin
b:=b+1;
if b<=10 then c:=c+a;
end;
c:=c*a;
end;
writeln(b,' ',c);
end.

Ответить

Другие вопросы из категории

Дан одномерный массив целых чисел размерностью 20.

Определите количество положительных групп в этом массиве.
(группа это последовательность состоящая из 2-х и более положительных чисел находящихся рядом.)

Нужно решить задачу в Паскале, условие таково:

"Найти наименьшее кратное двух чисел a и b"

Насколько я помню в этой задаче можно использовать команду Break.


Читайте также

ПОМОГИИИИТЕЕЕЕ!!!!!!!ОООЧЕНЬ СРООЧНОО!!! Тема Компьютерное моделирование. Предложите этапы построения компьютерной модели для решения одной из следующих

задач.Задача решается в Pascal ABC 1.В искусственный водоём запустили 100000 рыб. Ежегодно из водоёма забирают 12% рыб.Естественный прирост составляет 20%.Какое кол-во рыб будет в водоёме через 8 лет??



Вы находитесь на странице вопроса "Помогиииитееее!!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.