Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Ребята помогите пожалуйста перевести этот код с паскаля на с++.

10-11 класс

var a, b, c : integer;

Natag81 15 июля 2013 г., 6:59:51 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
SVG2023
15 июля 2013 г., 7:54:44 (10 лет назад)

#include <stdio.h>
#include <math.h>
int a,b,c;

int main(){
freopen("input.txt","r",stdin);
freopen("output.txt","w",stdout);
  scanf("%ld%ld",&a,&b,&c);
if (sqrt(c) = sqrt(a) + sqrt(b)) 
 printf("%ld" primoygolnyi); 
if (sqrt(c) > sqrt(a) + sqrt(b))
 printf("%ld" typoygolnyi'); 
if (sqrt(c) < sqrt(a) + sqrt(b)) then write('ostroygolnyi');
  printf("%ld"ostroygolnyi");
return 0;
}

+ 0 -
Mmhishnik2013
15 июля 2013 г., 10:01:29 (10 лет назад)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cmath>
using std::pow;
int main()

   int a, b, c;

   cout << "Vvedite storoni treygolnika: ";
   cin >> a >> b >> c;

   if(pow(c, 2) == pow(a, 2) + pow(b, 2)) 
   {
      cout << "Pryamoygolniy" << endl; 
   } 
   else if(pow(c, 2) > pow(a, 2) + pow(b, 2))
   {
      cout << "Typoygolniy" << endl;
   } 
   else
      cout << "Ostroygolniy" << endl;}

+ 0 -
Nadina2014
15 июля 2013 г., 12:45:48 (10 лет назад)

помог?

+ 0 -
Alinka333
15 июля 2013 г., 14:41:01 (10 лет назад)

компилятору вот эта строчка не нравится, а точнее после знака равно

+ 0 -
Mihail20035012
15 июля 2013 г., 17:17:56 (10 лет назад)

if (sqr(c) = sqr(a) + sqr(b)) then write('primoygolnyi');

+ 0 -
Amantaev2000
15 июля 2013 г., 18:02:46 (10 лет назад)

ой ошибся, вот эта строчка if (sqrt(c) = sqrt(a) + sqrt(b))

+ 0 -
WaRRioR111
15 июля 2013 г., 20:57:37 (10 лет назад)

сори

Ответить

Читайте также

прооошу помогите перевести этот код delphi в паскаль,плиииз

program TaskFormula;
uses
var x, a, xn, xk, dx, sum, multiplNegative: real;
countNegative: integer;
j,m,f:real;
y: Real;
begin
writeln('a --> ');
Read(a);
writeln(' xn --> ');
Read(xn);
writeln(' xk --> ');
Read(xk);
writeln(' dx --> ');
Read(dx);
sum := 0;
multiplNegative := 1;
countNegative := 0;
x := xn;
While (x <= xk) do begin if (a+x < 0) then begin f:=(a+x)*-1;
f:=ln(f)*(-1);
j:= RoundTo(abs(a-sqr(x)) * f,-5);
end
else
j:= RoundTo(abs(a-sqr(x)) * ln(a+x),-5);
m:= Power(sqr(x),1/3)+ Power(a,1/5);
if j<0 then begin j:=j*(-1);
j:= Power(j, 1/3);
j:=j*(-1);
end
else
j:= Power(j, 1/3);
y:= RoundTo(j/m,-5);
write('x= ',x:5:3,' ');
writeln('y= ',y:7:5);
if y<0 then
begin
sum := sum + y;
multiplNegative := multiplNegative * y;
inc(countNegative);
end;
x:= x + dx;
end;
writeln;
writeln(' y = ',countNegative);
writeln('y = ',sum:7:5);
writeln(' y = ',multiplNegative:7:5);
Readln;
end.

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Здавствуйте ребята!Помогите пожалуйста решить,перевесети из двочного кода в десятичный код.Числа записаны в парах : 1)101 101 2)1000

1000

3)1001 1000

4)1011 110

5)1100 110

6)1100 111

7)1011 111

8)1011 10

9)1001 10

10)1001 11

11)1010 11

12)1010 100

13)111 100

14)111 10

15)101 10

16)101 11

17)110 11

18)110 1001

19)111 1001

20)111 1000

21)10 1000

22)10 1001

23)11 1001

24)11 110

25)100 101

Или подскажите как решать хотя бы:))Заранее спасибо.



Вы находитесь на странице вопроса "Ребята помогите пожалуйста перевести этот код с паскаля на с++.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.