Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

даны 2 точки а (х1;у1) и b(х2;у2) определить какая из точек находиться ближе к началу координат . записать на языке паскаль

5-9 класс

Sss2010 02 дек. 2016 г., 2:58:35 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
НастяКД
02 дек. 2016 г., 4:22:29 (7 лет назад)

program gt;
var x1,x2,y1,y2:real;
begin
readln(x1,y1,x2,y2);
if(x1*x1+y1*y1)<(x2*x2+y2*y2)then writeln('первая точка ближе')else
if(x1*x1+y1*y1)>(x2*x2+y2*y2)then writeln('вторая точка ближе')else writeln('одинаково расположены');
end.

Ответить

Другие вопросы из категории

аскстеа-нужно составить слово
Ребят, помогите пожалуйста! Завтра сдавать!!

В книге 1024 стр. Информационный объём=4мб.
Сколько строк на одной стр., если 1 строка=64 символа.
1 символ=16 бит

1. От разведчика была получена следующая шифрованная радиограмма, переданная с помощью азбуки Морзе: -..-..--..----. При передаче радиограммы было

потеряно разбиение на буквы, но известно, что использовались только следующие буквы: И А Н Г Ч .Определите текст радиограммы.
И ..
Н -.
Г --.
Ч ---.

Читайте также

P.S решить задачи 1. мальчик может бегать в три раза быстрее,чем ходить .Скорость его ходьбы составляет 4км/ч. Он принял участие в марафонском

забеге, но сошел с дистанции, пробежав X км. Сколько времени он затратил но преодоление этой дистанции?

2.Даны две точки на плоскости (х1 ; у1) и (х2; у2). Необходимо определить какая из точек находится дальше (ближе) от начала коорддинатных осей.

3. Написать программу, распознающую по длинам сторон среди всех треугольников прямоугильные.

4. Определить в вещественном числе количество цифр до запятой.

5. В линейной таблице из 16 элементов все числа хранятся в порядке возврастания. Необходимо все числа в таблице расположить в порядке убывания

Даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу координат.

Примеры входных данных: координаты 1-ой точки>> 1,2..

координаты 2-ой точки>> 3,4..

Примеры выходных данных: 1-ая точка ближе...Помогите пожалуйста.

На плоскости заданы две точки А с координатами (х1, у1) и В с координатами (х2,у2) Координаты точек вводятся с клавиатуры. Определить какая из точек ближе

к началу координат и вывести на экран соответсвующее сообщение
Составьте пожалуста программу в паскале



Вы находитесь на странице вопроса "даны 2 точки а (х1;у1) и b(х2;у2) определить какая из точек находиться ближе к началу координат . записать на языке паскаль", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.