Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

с клавиатуры вводится число, если число принадлежит промежутку от 10 до 30, то его умножают на три, иначе умножают на -1, результат вывести на экран

5-9 класс

Софулика 25 марта 2017 г., 3:13:22 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vikabasok
25 марта 2017 г., 5:19:43 (7 лет назад)

на си пойдет?

#include <iostream>
using namespace std;
int main()
{
    int n,m;
    cin >> n;
    if (n >= 10 && n <= 30)
        m = 3n;
    else
        m = -n;
    cout << m;
}

+ 0 -
Denkubran
25 марта 2017 г., 6:48:35 (7 лет назад)

на паскале: 

var i:integer;

begin
readln(i);
if (i in [10..30]) then writeln(i*3) else writeln(i*(-1));
end.

Ответить

Другие вопросы из категории

Постройте электронную таблицу " Оплата электроэнергии " для расчёта ежемесячной платы за расход электроэнергии в течение года. Исходный информацией

являются показания счетчика в начале каждого месяца и стоимость одного киловатт-часа.

Примером процесса обработки информации есть:

1.распространение сведений средствами массовой информации
2.сохранение структуры данных и их значений
3.ограничение доступа к данным
4.создание банков данных и баз знаний


СРОЧНО ПОМОГИТЕ ПЛИЗ

задали сделать игру в повер поинт я почти сделал но от вас требуется чтобы можно было вводить название 2 команд и чтобы считались правельные ответы(очки)нечего изменять ненада я сам всё доделаю
просто нужно возможность писать 2 команды и считали очки,балы,правелльные ответы
ниже я преложил сам документ

Помогите решить задачи.

1.Алфавит содержит 256 букв. какое количество информации несет одна буква.
2.Сообщение, записанное буквами из 256 символьного алфавита, содержит 20 символов. Какой объем информации в битах оно несет?
3.Информационное сообщение объемом 600 бит содержит 150 символов. Какова мощность алфавита?
4.Объем сообщения, содержащего 50 символов, составил 250 бит. Каков размер алфавита, если объем его составил 200 бит?
5.Сколько символов содержит сообщение, записанное с помощью 16 символьного алфавита, если объем его составил 200 бит?
6.В книге 90 страниц. На каждой странице 60 строк по 80 символов в строке. Вычислить информационный объем книги.

Читайте также

с клавиатуры вводится число х. если

с клавиатуры вводится число х. если остаток от деления х на 6 равен 2, то значение f(x)=4*x^2 если остаток от деления х на 6 равен 3, то значение f(x) = корень из х , если остаток от деления на 6 =0 то f(x) = x.


Написать программу в паскале используя операторы if и else . Нарисовать блок схему

ОЧЕНЬ НУЖНО !!!!!!!!!!!!!!!!!!!Дано натуральное число , если оно двузначное и делится на сумму своих цифр, то его разделить на эту сумму, если оно

трехзначное и делится либо на 7, либо на 11, то его разделить на цело на 11. В остальных случаях разделить число на 10. ( сделать с помощью программы Pascal) Заранее огромное спасибо))))

На планете Триа использую только числа от 1 до 27. Их записывают с помощью символов «<»,«.» и

«>». Запись числа N выполняется по следующему алгоритму:

1) весь интервал (1..27) делится на 3 равные части: от 1 до 9, от 10 до 18 и от 19 до 27.

2) если число N оказалось в первом интервале, записываем символ «<», если во втором­ символ «.», и если в третьем­ – символ «>»

3) делим оставшийся интервал (в который попало число N) на три части и определяем следующий знак кода, который записывается справа от предыдущих

4) повторяем шаги 2 и 3 до тех пор, пока оставшийся интервал не будет содержать одно число.

Например, число 22 будет закодировано как «>.<» (интервалы 19-27, 22-24, 22).

Определите, какое число записывается как «.<>»?

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.



Вы находитесь на странице вопроса "с клавиатуры вводится число, если число принадлежит промежутку от 10 до 30, то его умножают на три, иначе умножают на -1, результат вывести на экран", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.