Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Создать блок схему для следующей задачи (разветвленный алгоритм): Ввести с клавиатуры число (любое). Если число положительно, то нарисовать круг. Если

10-11 класс

отрицательное или равно 0 - закрашенный прямоугольник помогите плиз написать программу для QBASIC

Вазик 09 авг. 2013 г., 11:01:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sova021998
09 авг. 2013 г., 12:34:38 (10 лет назад)

Все во вложении,там в ворде блок схема,в тестовике прога,просто формат на bas поставь и компилируй свободно

Сама прога:

PRINT "Vvedite chislo x!"
INPUT x
CLS
SCREEN 12
IF x > 0 THEN
CIRCLE (15, 20), 5, 15
ELSE
LINE (15, 200)-(200, 300), 5, BF
END IF
END

Ответить

Другие вопросы из категории

переведите 16-ричное число 3АС9 в двоичную систему, а двоичное число 10001110101 -- в 16-ричную, используя тетрады. Разбиение на тетрады следует проводить

слева на право в целой части и с права на лево в дробной части двоичного числа.

Читайте также

Циклические алгоритмы.СоставьтеЦиклические алгоритмы.Составьте блок- схему для решения следующих задач:

1) Вводятся 100 чисел.Определить сколько среди них положительных и сколько отрицательных.(Числа вводятся в одну переменную в цикле)
2) Алгоритм вычисления суммы квадратов десяти производных чисел, водимых с клавиатуры в процесс выполнения алгоритма
И НАПИШИТЕ ПРОГРАММУ ДЛЯ КАЖДОЙ ЗАДАЧИ

Дан фрагмент программы. Нарисуйте блок-схему, восстановите вид формулы для расчета S

PASCAL:

VAR
A:ARRAY[1...100]OFF
INTEGER;
N,I,J: INTEGER;
S: REAL;
BTGIN
N:=8;
FOR I:=1 TO N DO
BEGIN
S:=0;
FOR J:=1 TO I DO
S:=S+(A[J]);
S:=ABS(S);
WRITELN(`S`=`,S:9:2);
END;
READLN;
END.

QBASIC
DEFINT N,I,J,S,
DIM A(100) AS INTEGER
N:=8
FOR I=1 TO N
S=0
FOR J=1 TO I
S=S+A[J]
NEXT J
S=ABS(S)
PRINT S
NEXT I

ШКОЛЬНЫЙ АЯ

алг слово(рез вещ s)
цел раб А[1:100]
n:=8
нц для I от 1 до n
s=0
нц для j от 1 до I
s=s+a[j]
кц
s=abs(s)
вывод s
кц
кон

Пожааалуйста нужны блок-схемы для трех вариантов получения s







Вы находитесь на странице вопроса "Создать блок схему для следующей задачи (разветвленный алгоритм): Ввести с клавиатуры число (любое). Если число положительно, то нарисовать круг. Если", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.