Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Создать программу на языке С++, с помощью которой по введенному с клавиатуры числу получаешь его перевертыш (Например: вводишь 123, выходит 321)

10-11 класс

Zinkovskaya1 30 июня 2014 г., 1:18:54 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
мирим
30 июня 2014 г., 2:35:59 (9 лет назад)

#include <iostream>
using namespace std;

int main()
{
   int n,count = 0,k = 1;
   unsigned int m;
   cout <<"N = ";
   cin >>n;
   m = n;
   while (m!=0)
   {
       ++count;
       m/=10;
   }
   for (int i = 1; i<=count-1; i++)
       k*=10;
   while (n!=0)
   {
       m+=n%10*k;
       k/=10;
       n/=10;
   }
   cout <<"Resultat: " <<m <<endl;
   return 0;
}

Ответить

Другие вопросы из категории

1)Вы подошли к светофору, когда горел желтый цвет. После этого загорелся зеленый. Какое количество информации вы при этом получили?

Я ответила, что всего 2 варианта. Оба можно записать 1 битом. Т.о., если я знаю о том, что горит желтый свет, то мне одним битом можно объяснить. что загорелся сигнал "выше желтого", либо "ниже желтого." 2)Вы подошли к светофору, когда горел красный свет. После этого загорелся желтый. Сколько информации вы при этом получили?

Получите внутреннее представление

десятичного числа 1457 в ячейках памяти.

Читайте также

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Написать программы на языке С++

1) С клавиатуры вводится 2 числа - целое и вещественное. Программа выводит их сумму на экран.
2) Написать процедуру, которая умножает число типа int на число типа float на число типа double и выводит результат на экран
3) Написать процедуру, которая будет выводить любой текст, являющийся ее аргументом
4) С клавиатуры вводится 5 символов поочередно, программа выводит на экран акроним к слову которая образует эти 5 символов

помогите коле и напишите программу или алгоритм которое находит все просые числа в диапазоне от m до N ВКлючительно

в задаче требуется написать программу которая по двум заданным числам находила бы в диапазоне между этими числами все простые числам где простое число которое имеет всего лишь два делителя то есть оно делится на единицу и на само себя и больше оно не на что не делиться например -3 7 11 помогите )) олимпиада по инфе )) даю максимум баллов ))



Вы находитесь на странице вопроса "Создать программу на языке С++, с помощью которой по введенному с клавиатуры числу получаешь его перевертыш (Например: вводишь 123, выходит 321)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.