Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

составить программу на языке паскаль АВС, которая запрашивает 4-е число и находит произведение цифры этого числа

10-11 класс

алекс25122003 23 сент. 2014 г., 11:10:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nik12371
23 сент. 2014 г., 12:51:57 (9 лет назад)

var 
a,b1,b2,b3,b4,s:integer; 
   begin 
writeln('введи число'); 
readln(a); 
b1:=a mod 10; 
b2:=(a mod 100) div 10; 
b3:=(a mod 1000) div 100; 
b4:=a div 1000; 
s:=b1*b2*b3*b4; 
writeln('Ответ ',s); 
end.

Ответить

Другие вопросы из категории

пожалуйста помагите.

Вычеслить произведение не четных чисел от 11 до 99 шагом в 2

к системе программ не относяться? драйверы увв

архиваторы

текстовые редакторы

Язык С.

Написать
программу, которая печатает объем памяти занимаемый одной переменной для типов
int, short int, long int, float и double.

Читайте также

Составить программу на языке паскаль

задание: дана матрица А(N, N). Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

1)Вычислить значения функции y=4*x^3-2*x^2+5 для x, изменяющегося от -3 до 1 с шагом 0,1 на языке ПАСКАЛЬ!!СРОЧНОО ЗАВТРА ЭКЗАМЕН РЕБЯЯТКИ!

2)Найти количество всех нечетных чисел на интервале от 11 до 20
3)Найти сумму целых положительных четных чисел на интервале от 1 до 100
4)Найти сумму ряда,общий член которого равен А(х)=1/(3*N-2)*(3*N+1)
5)Дано произвольное число n≤100.Определить количество цифр в числе
ОЧЕНЬ НУЖНО!!НА ЯЗЫКЕ ПАСКАЛЬ!ВЫРУЧАЙТЕ!

Составить программу на языке Паскаль.Определите, кратно ли трем значение целочисленной переменной X. Если это имеет место, то выведите на печать

значение Х с соответствующим сообщением, если нет, то выведите на печать "нет".
Помогите, пожалуйста, очень нужно)



Вы находитесь на странице вопроса "составить программу на языке паскаль АВС, которая запрашивает 4-е число и находит произведение цифры этого числа", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.