Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составить программу на языке Паскаль.Определите, кратно ли трем значение целочисленной переменной X. Если это имеет место, то выведите на печать

10-11 класс

значение Х с соответствующим сообщением, если нет, то выведите на печать "нет".
Помогите, пожалуйста, очень нужно)

Виктория2712 09 апр. 2015 г., 12:10:54 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Cristinuta
09 апр. 2015 г., 14:53:32 (9 лет назад)

program D23;
  uses crt;
    var
      X: integer;
      S: real;
begin
  clrscr;
  writeln('Введите число X: ');
  readln(X);
    S:=X mod 3;
    if S = 0 then
    writeln('Число ',X,' кратно 3!')
  else
    writeln('Число ',X,' не кратно 3!');
end.

Вот если я все правильно понял вас, проверьте программу в использовании чтобы убедится что получился тот результат если есть возможность.


+ 0 -
Valeriavas
09 апр. 2015 г., 16:16:34 (9 лет назад)

в смысле делится ли на 3) Буду очень благодарна, если поможете:)

+ 0 -
Vika2701905
09 апр. 2015 г., 18:52:01 (9 лет назад)

Вы имеете ввиду делится ли на 3 без остатка, так как целочисленное?

+ 0 -
Pusik565
09 апр. 2015 г., 20:49:33 (9 лет назад)

да

+ 0 -
Barsiksolo
09 апр. 2015 г., 21:30:05 (9 лет назад)

Еще надо?

+ 0 -
Таня2017
09 апр. 2015 г., 23:37:52 (9 лет назад)

да, на неделю задали 3 задачи, а я этот паскаль ну никак не поняла

Ответить

Другие вопросы из категории

дан вектор b[1:10] а)найти минимальный и максимальный элементы вектора.,)поменять местами максимальный и минимальный элементы. в)получить сумму

элементов между их номерами.г)Получить произведение отрицательных элементов. Помогите пожалуйста.

Написать программу проверки знания истории архитектуры. Программа должна вывести вопроси три варианта ответа. Пользователь должен выбрать

правильный ответ и ввести его номер.Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).
Архитектор Исаакиевского собора:
1. Доменико Трезини
2. Огюст Монферран
3. Карл Росси
Введите номер правильного ответа и нажмите <Enter>
= 2
Правильно.
Архитектор Исаакиевского собора - Огюст Монферран

на языке Turbo Pascal

решите задание в delphi 7 (бред не пишите плз)(без массива)

группа студентов сдает экзамен. оценки формируются случайным образом от 2 до 5. Напечатать кол-во полученых двок, трок, четверок, пятерок

Читайте также

Составить программу на языке паскаль

задание: дана матрица А(N, N). Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

Составить программу на языке Паскаль

Известна температура больного за 20 дней пребывания в больнице. Можно ли еговыписывать, если для этого требуется, чтобы не менее половины всех дней, когда у негобыла температура ниже 37°, приходилось на вторую половину его пребывания вбольнице?

1)Вычислить значения функции y=4*x^3-2*x^2+5 для x, изменяющегося от -3 до 1 с шагом 0,1 на языке ПАСКАЛЬ!!СРОЧНОО ЗАВТРА ЭКЗАМЕН РЕБЯЯТКИ!

2)Найти количество всех нечетных чисел на интервале от 11 до 20
3)Найти сумму целых положительных четных чисел на интервале от 1 до 100
4)Найти сумму ряда,общий член которого равен А(х)=1/(3*N-2)*(3*N+1)
5)Дано произвольное число n≤100.Определить количество цифр в числе
ОЧЕНЬ НУЖНО!!НА ЯЗЫКЕ ПАСКАЛЬ!ВЫРУЧАЙТЕ!

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.



Вы находитесь на странице вопроса "Составить программу на языке Паскаль.Определите, кратно ли трем значение целочисленной переменной X. Если это имеет место, то выведите на печать", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.