Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Укажите значения для переменных x и y после выполения операторов

5-9 класс

x:=2;
у:=5;
х:=у;
у:=х;
2. Какую задачу решает данная программа?
program primer
var a,b,c: integer;
begin
writeln("введите двухзначное число ");
readln(a);
b:=a div 10 ;
c:=a mod 10;
write(c*10+b);
end.
а)находит сумму цифр числа;
б)вычесляет целую часть и остаток от деления числа на 10 ;
в)меняет цифры числа местами
г)находит цифры числа, а на экран выводит само число
3. Среди предложенных выражения выбирете логические :
а) (x=3)or (x<>4)
б)2*x+5;
в)x mod 2=0;
г)x div 3
д) x+у=10
е) х+у
ж)(х+у>5)or(x-у>5)
з)(х>3)and (х<=10)
4. Составьте условие для условного оператора в программе , которая выводит на экран приветствие в зависимости от времени суток . Пусть утро с8 до 12 ч, день с12 до 17 ч , вечер с 17 до 23ч, ночь-всё остальное время.
program primer;
begin
writeln("Который час?");
readln(x);
if__________then writeln('Доброе утро!');if__________then writeln('Добрый день!');
if__________then writeln('Добрый вечер!');
if__________then writeln('Доброй ночи!");
if__________then writeln('Введите число выходит за рамки интервала [0,24]');

емеляw9 10 авг. 2014 г., 18:56:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ludavir
10 авг. 2014 г., 20:05:47 (9 лет назад)

1.) x =5, y=5.
2.) меняет цифры местами
3.) Всё то, что с or и and, а именно а,ж,з.
4.) if (x>=8 and x<12) then writeln('Доброе утро!');if if (x=>12 and x<17) then writeln('Добрый день!');
if (x>=17 and x<21) then writeln('Добрый вечер!');
if (x>=21 and x<=23) or (x>=0 and x<8) then writeln('Доброй ночи!");
if (x>24) or (x<0) then writeln('Введите число выходит за рамки интервала [0,24]');

Ответить

Другие вопросы из категории

1. Написать программу для определения количества двузначных чисел в диапазоне от А до B, которые при делении на 6 дают остаток 2. 2. Найти сумму

двузначных чисел в диапазоне от А до B, в которых первая цифра ровно в 2 раза больше второй.

Какая марка у этого рюкзака?
Два сообщения содержат одинаковое количество символов. Количество информации в первом тексте в 1,5 раза больше чем во втором. Сколько символов содержат

алфавиты с помощью которых записанные сообщения, если известно ,что число символов в алфавите не превышает 10 и на каждый символ приходится целое число

Читайте также

1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a := 3 + 8*4; b :=

(a div 10) + 14;

a := (b mod 10) + 2;

2) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 1819;

b := (a div 100)*10+9;

a := (10*b–a) mod 100;

3) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 42;

b := 14;

a := a div b;

b := a*b;

a := b div a;

4) Определите значение целочисленных переменных x, y и t после выполнения фрагмента программы:

x := 5;

y := 7;

t := x;

x := y mod x;

y := t;

5) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

а :=6*12 + 3;

b :=(a div 10)+ 5;

a :=(b mod 10)+ 1;

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

Помогите, пожалуйста, очень срочно. Желательно с полным решение. Заранее спасибо. 1) Определите значение целочисленных переменных a и b после выполнения

фрагмента программы: a := 3 + 8*4;
b := (a div 10) + 14;
a := (b mod 10) + 2; 2) Определите значение переменной c после выполнения следующего фрагмента программы:
a := 100
b := 30
a := a – b*3
if a > b then
c := a – b
else
c := b – a
еnd if

1) Исходное данное - целое трёхзначное число x. Выполните для x = 125 следующий алгоритм. a:=x div 100 b:=x mod 100 div 10

c:=x mod 10

s:=a+b+с.

Чем является результат s этого алгоритма?

2) Определите значение целочисленных переменных x и

y после выполнения фрагмента алгоритма.

x:=336

У:=8

x:=x div y

y:=х mod у

С помощью операции div вычисляется целое частное, с помощью операции mod - остаток.

1)Дан фрагмент линейного алгоритма.

а:=8

b:=6+3*а

а:=b/3*а

Чему равно значение переменной а после его исполнения?


Ваш ответ:

2)Исполните следующий фрагмент линейного алгоритм для а = х и b = y.

а:=а+b

b:=b-a

а:=а+b

b:=-b

Какие значения присвоены переменным a и b?

а)-у, х
б)y, х
в)х, у
г)х+у, х-у

3)Определите значение целочисленных переменных х и у после выполнения фрагмента программы.

х:=11

у:=5

t:=y

у:=х mod у

x:=t

y:=y+2*t

а)х = 10, у = 5
б)х = 5, у = 11
в)x = 11, y = 5
г)х = 5, у = 10

4)Среди четырёх монет есть одна фальшивая. Неизвестно, легче она или тяжелее настоящей. Какое минимальное количество взвешиваний необходимо сделать на весах с двумя чашками без гирь, чтобы определить фальшивую монету?

а)4
б)2
в)5
с)3



Вы находитесь на странице вопроса "Укажите значения для переменных x и y после выполения операторов", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.