Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Сост алг замены элементов массива от В[N],не больших 15,их кубами

5-9 класс

Tezka 11 сент. 2014 г., 13:16:57 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Qsdbn
11 сент. 2014 г., 15:52:58 (9 лет назад)

const
    n = 10;
    k = 15;

var
    a: array[1..50] of integer;
    i: integer;

begin
    for i := 1 to n do
    begin
        a[i] := random(40);
        write(a[i]:7);
        if a[i] < 15 then a[i] := a[i] * a[i] * a[i];
    end;
   
    writeln;
    for i := 1 to n do
        write(a[i]:7);
end.

+ 0 -
Alina428
11 сент. 2014 г., 18:07:25 (9 лет назад)

var
i,n: integer;
B:array [1..100] of integer;

begin
writeln('Введите длину массива: ');
read(n); 
for i:=1 to n do begin 
 writeln('Введите ',i,'-й элемент массива'); 
  readln(B[i]); 
   if B[i] <= 15 then B[i]:=B[i]*B[i]*B[i]; 
end;

for i:=1 to n do writeln('Результат: ',B[i]);
end. 

+ 0 -
Alexroygan
11 сент. 2014 г., 19:30:02 (9 лет назад)

спасибо) нужно составить пока алгоритм не для компьютера а на тетрадном листе) начало,если,цикл,конец,кцикл и тд

+ 0 -
Renata160801
11 сент. 2014 г., 20:29:07 (9 лет назад)

не знаю я такого)

Ответить

Другие вопросы из категории

Читайте также

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве

Дан целочисленный массив из 20 элементов. Элементы массива принимают значения от 0 до 10000 включительно. Написать программу, позволяющую найти и выв

ести максимальное значение среди трехзначных элементов массива, делящихся на 4. Если в исходном массиве нет трехзначного элемента, который делится на 4, то вывести сообщение о том, что такого числа нет.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

Школьный уровень 1.Найти все элементы массива b(n),большие или равные 0.На экран вывести номер элементо

в,их значения и количество.

2.В одномерном массиве целых чисел,содержащем 20 элементов,удалить k-ый элемент массива.Массив заполняется случайным образом числами от 0 до 50.

1) составьте программу заполнения элементов массива [1..10 ] случайнымии целыми числами на отрезке [ 0;35 ] и вывода на экран нечетных элементов и

кратных числу 3.

2) составьте программу , которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 100 и выводит на экран среднее арифмитическое элементов массива



Вы находитесь на странице вопроса "Сост алг замены элементов массива от В[N],не больших 15,их кубами", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.