Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

надо срочно

10-11 класс

Составить программу, которая для любого натурального числа печатает количество цифр в записи этого числа.
расписать все четко

Aigulshakramova 15 сент. 2016 г., 13:37:53 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Danisimo888
15 сент. 2016 г., 15:55:23 (7 лет назад)

Строками:
var s:string;
begin
WriteLn('vvedi chislo:');
ReadLn(s);
WriteLn('chislo cifr=',length(s));
ReadLn;
end;
Не строками:
var N,k:longint;
begin
write('N=');readln(N);
k:=0;
while N>0 do
begin
N:=N div 10;
k:=k+1;
end;
write('k=',k);
readln
end.

Ответить

Другие вопросы из категории

y=12x^2+4x+16 x=5,10,15, 20 нужен алгоритм
Как сделать эту задачу в Экселе, подскажите пожалуйста / MS Office Excel


Задан массив b1, b2, b3, … bn. Все элементы, равные 7 заменить единицей и подсчитать количество таких элементов.

Заранее БОЛЬШОЕ СПАСИБО

Читайте также



Вы находитесь на странице вопроса "надо срочно", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.