Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Определить, является ли треугольник со сторонами a,b,c прямоугольным. Если нет, то вычислить больший угол.

10-11 класс

Надо срочно и на паскале

бебебебеббебеееббб 27 сент. 2013 г., 9:51:58 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Galohkanysha
27 сент. 2013 г., 11:49:49 (10 лет назад)

Program abc;
Var a,b,c,i,n:integer;
begin
writeln('Введите А : ');
read(a);
writeln('Введите B : );
read(b);
writeln('Введите C : ');
read(c);
if (a*a=b*b+c*c) or (b*b=a*a+c*c) or (c*c = a*a+b*b) then writeln( 'Треугольник прямоугольный') else
if (a>b) and (a>c) then writeln('Больший угол образован сторонами b и c') else
 if (c>a) and (c>b) then writeln('Больший угол образован сторонами b и a')  else
 if (b>a) and (b>c) then writeln('Больший угол образован сторонами a и c');
 end.   

Ответить

Другие вопросы из категории

3. Каким термином называют способ обмена данными между двумя объектами, в том числе между пользователем и компьютерной программой?

Ответ:
4. Как называется программа, у которой есть версии для разных операционных систем? В ответе введите прилагательное.
Ответ:
5. Отметьте все прикладные программы.
операционная система
системы управления базами данных
электронные таблицы
графические редакторы
утилиты
6. Как называется программа, которая позволяет оформлять текст разными стилями и добавлять в документ рисунки и таблицы?
текстовый редактор
графический редактор
текстовый процессор
браузер
почтовый клиент
7. Отметьте все текстовые процессоры.
Блокнот
CorelDraw
OpenOffice Writer
Microsoft Word
Internet Explorer

Стремясь

привлечь покупателей, продавец указал скидку на весь товар 33%. Однако, сделал
(мелким шрифтом) примечание, что скидка указана в четверичной системе.

счисления.

Какую
реальную скидку получит покупатель с покупки, общей стоимостью 500 рублей?

Читайте также

Помогите,пожалуйста, написать программу по теме "Ветвление в алгоритмах" для Pascal. Задача: определить существует ли треугольник со сторонами AB

C и, если существует, то какой он (равнобедренный, равносторонний, произвольный).

Заранее большое спасибо!

ЭТО СРОЧНО ПОМОГИТЕ

Напишите программу, которая ответит на вопрос:

Является ли треугольник со сторонами a, b, c равносторонним?
Является ли треугольник со сторонами a, b, c равнобедренным?
Существует ли треугольник со сторонами a, b, c?
Лежит ли точка с координатами a и b в первой координатной четверти?
Являются ли заданные числа b и c квадратом и кубом числа a?
ТРЕБОВАНИЯ:

Программа вводит три вещественных числа и выводит пять строк с ответами на каждый из вопросов 1-5.
ИМЯ ФАЙЛА С ПРОГРАММОЙ = ВАШЕЙ ФАМИЛИИ

Программирование. Даны три вещественных числа a,b,c. Существует ли треугольник со сторонами a,b,c? program dz1; uses crt; var

a,b,c:integer;

begin

writeln('введите три числа: ');

readln(a,b,c)

а дальше не знаю помогите пожалуйста!!!!)



Вы находитесь на странице вопроса "Определить, является ли треугольник со сторонами a,b,c прямоугольным. Если нет, то вычислить больший угол.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.