Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

даны три натуральных числа. напишите программу в паскале , определяющую , существует ли треугольник с такими длинами сторон. Если такой существует , то

5-9 класс

определите его тип (равносторонний , равнобедренный, разносторонний) СРОЧНО! ЗАРАНЕЕ СПАСИБО.

Nazar200622 17 нояб. 2014 г., 17:14:42 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Uliashka23
17 нояб. 2014 г., 20:12:29 (9 лет назад)

var
a,b,c,k:integer;
begin
readln(a,b,c);
if (a+b>c)and(b+c>a)and(a+c>b) then begin
writeln('треугольник существует');
k:=1
end
else writeln('треугольник не существует');
if (a=b)and(a=c) and (k=1) then
writeln('равносторонний');
if (((a=b)and(a<>c))or((c=b)and(c<>a))or((c=a)and(c<>b)))and (k=1) then
writeln('равнобедренный');
if (a<>b)and(c<>b)and(a<>c)and (k=1) then
writeln('разносторонний')
end.

Ответить

Читайте также

Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон. Если существует, определите его тип

Имеются данные о количестве полных лет трех призеров спартакиады. Напишите программу, выбирающую и выводящую возраст самого младшего призера.

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

Пожалуйста, помогите! До вечера нужно сделать, тему пропустила. Помогите, 9 - 11 класс.

Даны три натуральных числа. Напишите программу(на языке Паскаля), определяющую, существует ли треугольник с такими длинами сторон. Если такой треугольник существует, то определите его тип(равносторонний, равнобедренный, равносторонний).

(Спам и неправильные решения будут отправлены модетатору).

РЕШИТЕ ХОТЬ ЧТО-НИБУДЬ!!!:з 1.Линейные программы Напишите программу на ШАЯ.Вычислите значения следующих выражений: f=t*t/2+t

2.Условный оператор(ветвление)

Нарисуйте блок-схему.Дано два числа.Верно ли, что он равны?

3.Циклы

Напишите программу на Паскале. Выведите на экран табицу умножения на 4 в виде 1+4=4,2+4=8,....9*4=36.

4.Одномерные массивы

Напишите программу на Паскале.Подсчитайте количество максимальных элементов массива А [1..12].

5.Двумерные массивы

Напишите программу на Паскале. создать массив случайны чисел В[1..6,1..6].Все элементы массива, расположенные выше главной диагонали сделать равными О.Вывести исходный и исправленный массивы.



Вы находитесь на странице вопроса "даны три натуральных числа. напишите программу в паскале , определяющую , существует ли треугольник с такими длинами сторон. Если такой существует , то", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.