Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

даны Н целых чисел найти среднее арифметическое чисел/пожалуйста!!!

5-9 класс

Ilivakina 29 авг. 2014 г., 20:13:50 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Saito23
29 авг. 2014 г., 21:33:15 (9 лет назад)

var
M: array [1..100] of integer;
s,i,n: integer;
begin
write('Введите кол-во чисел (n): ');
readln(n);
writeln('Введите ',n,' чисел:');
for i:= 1 to n do
 begin
 
readln(M[i]);
 s:=s+M[i];
 end;
writeln('Среднее арифметическое: ',s/n);
end.  

Ответить

Читайте также

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 9, или вывести NO, если таких чисел в последовательности нет.

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!



Вы находитесь на странице вопроса "даны Н целых чисел найти среднее арифметическое чисел/пожалуйста!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.