Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Создать массив B из четных элементов массива (a1,a2..a30)

10-11 класс

Пончик20022 18 авг. 2016 г., 15:27:29 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MeikaInoKamI
18 авг. 2016 г., 16:08:08 (7 лет назад)

#include <stdio.h>

int main(void){
int a[30],b[30];

Ответить

Другие вопросы из категории

№2. Составить программу для решения задачи:

задайте целое число; определите, кратно ли оно 10.

организация циклов в паскаль
Считайте массив

из n
целых чисел с клавиатуры. Поменяйте
местами минимальный и максимальный
элементы.

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

Программирование в VBA. Задача:Массив сотоит из двадцати элементов. Сколько элементов массива нужно сложить (начиная с первого), чтобы сумма превысила

число 100. Вот моя программа:

Private Sub CommandButton1_Click()
Dim C(1 To 20) As Integer
Dim I, N, S As Integer
For I = 1 To 20
C(I) = Cells(I, 1)
Next I
S = 0
N = 0
For I = 1 To 20
If S <= 100 Then S = S + C(I) And N = N + 1
Next I
Cells(2, 3) = "Количество элементов массива, сумма которых превышает 100=" & N
End Sub

как результат выводит "0" (т.е. N заданное изначально). Может, кто-то сможет подсказать ошибку? Это срочно!

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.



Вы находитесь на странице вопроса "Создать массив B из четных элементов массива (a1,a2..a30)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.