Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Турбо паскаль помогите пожалуйста) дан двухмерный массив, найти количество

10-11 класс

элементов массива меньших 5

MiLaФФka 13 сент. 2016 г., 4:40:15 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Poborcevairen1
13 сент. 2016 г., 6:22:19 (7 лет назад)

Var a: array [0..5, 0..10] of integer;
    i, j, c: integer;
begin
     for i := 0 to 5 do
         for j := 0 to 10 do
             a[i, j] := random(10);

     for i := 0 to 5 do
         for j := 0 to 10 do
             writeln('[', i, ', ', j, '] => ', a[i, j]);

     for i := 0 to 5 do
         for j := 0 to 10 do
             if (a[i, j] < 5) then c := c + 1;
     writeln(c);
end.

Ответить

Другие вопросы из категории

Найдите ошибку Uses crt;

Var n,i,k,sum:integer;
sr:real;
m:array [1..100] of integer;
begin clrscr; Writeln ('Vvedite kol-vo chisel ');
Readln (n); For i:=1 to n do begin writeln ('vvedite ',i,' chislo ');
Readln (m[i]); end; writeln (' Polycheny chisla ');
For i:=1 to n do write (m[i]:4);
for i:=1 to n do if m[i]>0 then begin m[i]:=sin(i)*cos(i);
sum:=sum+m[i];
k:=k+1;
Sr:=sum/k;
end;
Writeln;
Writeln ('Sr = ',sr:4:2);
Readln;
end.

Что из перечисленных не является объектом электронной таблицы

А)диаграмма Б)вопрос С)книга Д)столбец

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

Паскаль. Помогите, пожалуйста)))

Дан двумерный массив целых чисел. В каждом столбце найти количество элементов кратных a и b.

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.



Вы находитесь на странице вопроса "Турбо паскаль помогите пожалуйста) дан двухмерный массив, найти количество", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.