Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

три точки А(х₁;у₁),В(х₂;у₂),С(х₃;у₃) задаются своими координатами.Написать программу, которая определяет,какая из этих точек ближе к началу координат.

5-9 класс

девчена 09 нояб. 2014 г., 11:23:10 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alrogojin
09 нояб. 2014 г., 14:10:53 (9 лет назад)

var
x1,x2,x3,y1,y2,y3,r1,r1,r3: real;
begin
writeln ('введите координаты A');
readln (x1,y1);
writeln ('введите координаты B');
readln (x2,y2);
writeln ('введите координаты C');
readln (x3,y3);
r1:=sqrt(x1*x1+y1*y1);
r2:=sqrt(x2*x2+y2*y2);
r3:=sqrt(x3*x3+y3*y3);
if (r1<=r2) and (r1<=r3) writeln('точка А ближе');
if (r2<=r1) and (r2<=r3) writeln('точка B ближе');
if (r3<=r1) and (r3<=r2) writeln('точка C ближе');
readln;
end

+ 0 -
Elenkarapetyan2
09 нояб. 2014 г., 14:50:39 (9 лет назад)

координаты вводим с клавиатуры? или можно сразу в программе забить?

+ 0 -
Beka7705
09 нояб. 2014 г., 17:23:27 (9 лет назад)

с клавиатуры вводм

Ответить

Другие вопросы из категории

Помогите пожалуйста срочно!!
Строки (цепочки латинских букв) создаются по следующему правилу. Первая строка состоит из одного символа - латинской буквы "А". Каждая из последующих

цепочек создается такими действиями: в очередную строку сначала записывается буква, чей порядковый номер в алфавите соответствует номеру строки (на i-м шаге пишется "i"-я буква алфавита), к ней слева и справа приписывается предыдущая строка. Вот первые 3 строки, созданные по этому правилу:
(1) A
(2) ABA
(3) ABACABA
Запишите шесть символов подряд, стоящие в седьмой строке со 122-го по 127-е место (считая слева направо).

Читайте также

Нужно подробное написание программы в pascalABC

1) С клавиатуры вводится число в интервале от 1 до 999. Написать программу, которая определяет количество цифр во введенном числе.
2) Написать программу, которая определяет, какая из двух точек расположена ближе к началу координат. Координаты вводятся с экрана.

Задача «Справедливое распределение»

У Андрея было А грамм крупы, у Бориса – В
грамм, а у Сергея вообще не было крупы.

Ребята сварили кашу и разделили ее поровну
на троих. Поскольку Сергей был без крупы, то

в благодарность за кашу он отдал С конфет
Андрею с Борисом.

Требуется написать программу, которая
определяет, как Андрей и Борис должны

поделить конфеты по справедливости.
Конфеты делить на части нельзя.

Описание входных данных

Входные данные вводятся с клавиатуры или
из файла input.txt. В единственной

строке записаны три целых числа А, В и С.

Описание выходных данных

Выходные данные выводятся на экран или в
файл output.txt. В единственной

строке необходимо вывести два целых числа
— количество конфет у Андрея и количество

конфет у Бориса.

Пример входных и выходных данных

Входные данные Выходные данные

700 500 12 9 3

2 задачи по программированию: 1) Три точки заданы своими координатами (x1,y1),

(x2,y2), (x3,y3). Напишите программу, позволяющую выяснить, какие из них находятся на максимальном расстоянии друг от друга, и вывести на печать значение этого расстояния. Вычисление расстояния между двумя точками оформите в виде процедуры.

2) Даны действительные числа Х и Y. Напишите программу, позволяющую вычислить значение следующего выражения:

Z=(signX + signY)*sign(X+Y),

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

Составить программу, которая определяет, являются ли разные точки с координатами (X1,Y1) и (X2, Y2) симметричными относительно осей координат или

начала координат.

прочертить путь выполнения алгоритма для следующих значений параметров:

А) X1= -1, Y1=6, X2=1, Y2=6.

Б) X1=6, Y1=7, X2=1, Y2=6



Вы находитесь на странице вопроса "три точки А(х₁;у₁),В(х₂;у₂),С(х₃;у₃) задаются своими координатами.Написать программу, которая определяет,какая из этих точек ближе к началу координат.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.