Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите написать программы в Delphi для возведения числа в степень.

10-11 класс

Taga2701 28 авг. 2013 г., 16:38:58 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Olgavarlamova08
28 авг. 2013 г., 17:21:43 (10 лет назад)

function Pow(x, y: real): real;
var
  PowTmp: real;
begin
  if (x < 0) then 
    PowTmp := (-1) * Exp(y * Ln(Abs(x))) 
  else if (x > 0) then 
    PowTmp := Exp(y * Ln(Abs(x))) 
  else PowTmp := 0; 
  if not (odd(round(y))) then PowTmp := Abs(PowTmp); 
  if (y = 0) then PowTmp := 1; 
  Pow := PowTmp; 
end;

Вот функция, приклейте, куда нужно:)

+ 0 -
Alinalinka1
28 авг. 2013 г., 17:55:19 (10 лет назад)

Комментарий удален

+ 0 -
Idievmalik57
28 авг. 2013 г., 19:17:30 (10 лет назад)

var
a,i,b,x:integer;
begin
read(a,b);
x:=a;
for i:=2 to b do x:=x*a;
write(x);
end.
Если что, то так...

+ 0 -
Eminov
28 авг. 2013 г., 21:13:09 (10 лет назад)

Комментарий удален

+ 0 -
StepanGamer
28 авг. 2013 г., 21:59:53 (10 лет назад)

Комментарий удален

+ 0 -
богзнаний2001
29 авг. 2013 г., 0:15:41 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

в паскале abc помогите написать программу.

Дано натуральное число N. С клавиатуры вводятся N дат рождения в
формате DD.MM.YYYY (например, 17.04.2014). Напечатать название месяца, в
котором больше всего дней рождений. Если таких месяцев несколько, то
напечатать название самого позднего из них.

Дали второе задание, исходя из этого:http://znanija.com/task/4120829

Нужно составить программу, которая так же выводит числа, только главное условие - чтоб выводимые числа делились и на 2, и на 3, и на 5
рабочая программа для вывода кратных 2,3 и 5:
Private Sub CommandButton1_Click()Dim i As IntegerDim n As Integern = InputBox("До какого числа выводить результат?")
Dim Massiv() As IntegerDim s As IntegerFor i = 0 To nIf (i Mod 2) = 0 Or (i Mod 3) = 0 Or (i Mod 5) = 0 ThenReDim Preserve Massiv(s)Massiv(s) = is = s + 1Range("A" & CStr(s)).SelectActiveCell.FormulaR1C1 = Massiv(s - 1)End IfNext
End Sub

Читайте также

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.



Вы находитесь на странице вопроса "Помогите написать программы в Delphi для возведения числа в степень.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.