Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Нужно написать на Паскале=))

10-11 класс

Дан набор слов, разделенных точкой с запятой (;), который заканчивается двоеточием (:). Определить, сколько в нем слов, заканчивающихся буквой «а»

Allazhu2012 24 дек. 2016 г., 10:52:25 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Только123456
24 дек. 2016 г., 11:37:47 (7 лет назад)

var s : string;
  i, k : integer;
Begin
  read(s);

  for i:=1 to length(s)-1 do
    if (s[i] = 'а') and ((s[i + 1] = ';') or (s[i + 1] = ':')) then
      k := k + 1;

  write(k);
End.

+ 0 -
Lilia1122381
24 дек. 2016 г., 14:04:29 (7 лет назад)

Какой именно паскаль?

+ 0 -
Snytkinareta
24 дек. 2016 г., 15:55:34 (7 лет назад)

Пофиг. Составил для абц.
var s:string;
var i,k:integer;
begin
read(s);
k:=0;
for i:=2 to length(s) do
begin
if (s[i]=';') or (s[i]=':') then if s[i-1]='а' then k:=k+1;
if s[i]=':' then break;
end;
write(k);
end.

+ 0 -
Aminiature30
24 дек. 2016 г., 18:31:26 (7 лет назад)

Sergrif, ты бы в ответ это записал, а то решаешь, а кто-нибудь потом это за свое выдает)))) и кстати, я все для АБС пишу, смысл мне с другими заморачиваться? им надо, пусть и конвертируют)))

+ 0 -
Kamila4539
24 дек. 2016 г., 19:51:06 (7 лет назад)

спасибо,очень выручили=))

Ответить

Читайте также

Вводится последовательность целых чисел, по абсолютной величине меньших или равны 100. Найти и вывести на печать количество отрицательных чисел и сумму

всех чисел, расположенных после первого нулевого элемента.
Написать на Паскале буду очень благодарен!!

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!



Вы находитесь на странице вопроса "Нужно написать на Паскале=))", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.