Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

С1. Составьте программу, которая вводит с клавиатуры три различных целых числа, каждое из которых по абсолютной величине не

10-11 класс

превосходит 100 (каждое число – с новой строки), и выводит на экран число, равное произведению максимального и минимального из них, если минимальное число отрицательно; или сумме максимального и минимального из них, если минимальное число неотрицательно.

Ничего, кроме указанного числа, программа выводить не должна.

С2. Составьте программу, которая вводит с клавиатуры натуральное число N, не превосходящее 12, а затем N целых неотрицательных чисел ( каждое чисол - с новой строки), записывает эти N чисел в массив, выводит на экран сначала в обратном порядке все, без исключения, элементы массива, затем, в прямом порядке относительно следования в массиве, все элементы, остаток которых от деления на 8 равен 3.
Каждое число программа должна выводить в отдельной строке; ничего, кроме чисел, программа выводить не должна.

С3. См. фото.



4797 22 янв. 2017 г., 2:11:05 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Антин
22 янв. 2017 г., 3:39:38 (7 лет назад)

По первой задаче, предполагается, что пользователь корректно всё ввёл:

program c1;
uses crt;
var b:array[1..3] of shortint;
min:integer;
max:integer;
i:integer;
begin
for i:=1 to 3 do
begin

readln(b[i]);
if(i=1) then
begin
min:=b[i];
max:=b[i];
end;
if(b[i]<min) then
begin
min:=b[i];
end;
if(b[i]>max) then
begin
max:=b[i];
end;
end;

if(min<0) then
begin
writeln(min*max);
end else
begin
writeln(min+max);
end;
end.

------------------------------------------------------------------------------------------------

Задача номер 2

program c2;
uses crt;
var b:array[1..12] of word;
i:integer;
N:byte;
begin
readln(N);
for i:=1 to N do
begin
readln(b[i]);
end;

for i:=N downto 1 do
begin
writeln(b[i]);
end;

for i:=1 to N do
begin
if b[i] mod 8 = 3 then writeln(b[i]);
end;

 

end.

----------------------------------------------------------------------------------

Задача номер 3

program c3;
uses crt;
var x,y:real;
begin
readln(x);
readln(y);
{check e or not e}
if(x*x + y*y)>4 then
begin
writeln('E'); {snaruzhi okruzhnosti}
end else
begin
if(y>3*x) then {C ili B}
begin
if(y>-3*x) then writeln('B') else writeln('C');
end else {A ili D}
begin
if(y>-3*x) then writeln('A') else writeln('D');
end;
end;


end.

в третьей задаче 1 проверяем точка в окружности или за окружностю, затем проверяем выше она первой прямой или ниже, и также со второй прямой. в зависимости от результатов проверки делаем вывод. Задавайте вопросы

 

Ответить

Другие вопросы из категории

Нужно написать на Паскале=))

Дан набор слов, разделенных точкой с запятой (;), который заканчивается двоеточием (:). Определить, сколько в нем слов, заканчивающихся буквой «а»

Переведите

в восьмеричную систему число F3,7С16. Чему равно это число в десятичной
системе?




Читайте также

Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" Напишите программу,

которая отвечает на вопрос: "Существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"
Входные данные. Два числа N (1 \leq N \leq 10000000000), k (1 \leq k \leq 100)
Выходные данные. Программа выводит два таких числа, если они существуют, "NO" - если нет.

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

Поле шахматной доски представляется парой натуральных чисел, каждое из которых не превосходит восьми: первое число - номер вертикали (при счете снизу

вверх), второе - номер горизонтали (при счете слева направо). Даны натуральные числа k, l, m,n, каждое из которых не превосходит восьми. Требуется:

1. выяснить, являются ли поля (k, l) и (m, n) полями одного цвета

2. на поле (k, l) расположен ферзь. Угрожает ли он полю (m, n)?

задача в Delphi.



Вы находитесь на странице вопроса "С1. Составьте программу, которая вводит с клавиатуры три различных целых числа, каждое из которых по абсолютной величине не", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.