Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Декодировать полученное сообщение c=1100011, если известно, что использовался (7, 4) – код

10-11 класс

Хэмминга. Провести кодирование кодом с проверкой четности.

(Просьба подробно расписать)

Olgarabontikki 03 авг. 2013 г., 5:02:09 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kolcova80
03 авг. 2013 г., 7:08:19 (10 лет назад)

#include <stdio.h>
#include <stdlib.h>
char input[1024];
int len;

int find_mistake()
  {    
    int i, mistake = 0;
        for (i = 0; i < len; i ++)
                if (input == '1')
                    mistake ^= i + 1;
                return mistake;
  }
     
  int main()
  {    
     int i, mistake = 0;    
     char info[1024];    
     int info_pos = 0;    
     int b = 1;    
     
     printf("Enter code: ");    
     scanf("%s", input);    
     len = strlen(input);    
     for (i = 0; i < len; i++)
             if (input != '0' && input != '1')
            {           

Ответить

Другие вопросы из категории

Задание Определить, изделия какой из двух групп товаров выгоднее сшить из одного рулона ткани, если известны: расход ткани на каждое изделие и цена

готового изделия, количество метров в рулоне. Помогите, нужно написать программу решения этой задачи в Паскале

Для передачи по каналу связи сообщения, состоящего только из букв А, Б, В, Г, решили использовать неравномерный по длине код: A=0, Б=10, В=110. Как нужно

закодировать букву Г, чтобы длина кода была минимальной и допускалось однозначное разбиение кодированного сообщения на буквы?
1) 1 2) 1110 3) 111 4) 11
--------------------------------------------------------
Здравствуйте, почему ответах правильный ответ под цифрой - '3'? Если для 1 варианта ответа, выполняется обратное условие Фано(в теории надо, что бы хотя бы одно из правил Фано выполнялось), и оно является минимальным. Спасибо!

Читайте также

Два сообщения содержат одинаковое количество символов. Количество информации в первом тексте в 2,5 раза больше, чем во втором. Какова мощность каждого из

алфавитов, с помощью которых записаны сообщения, если известно, что число символов в каждом алфавите не превышает 32 и на каждый символ приходится целое число битов?

На одной улице стоят в ряд 4 дома, в которых живут 4 человека: Алексей, Егор, Виктор и Михаил. Известно, что каждый из них владеет ровно одной из

следующих профессий: Токарь, Столяр, Хирург и Окулист, но неизвестно, кто какой и неизвестно, кто в каком доме живет. Однако, известно, что:

1) Столяр живет правее Хирурга

2) Окулист живет левее Хирурга

3) Токарь живет с краю

4) Токарь живет рядом с Окулистом

5) Егор не Токарь и не живет рядом с Токарем

6) Михаил живет рядом с Хирургом

7) Алексей живет правее Окулиста

8) Алексей живет через дом от Михаила

Выясните, кто какой профессии, и кто где живет, и дайте ответ в виде заглавных букв имени людей, в порядке слева направо. Например, если бы в домах жили (слева направо) Константин, Николай, Роман и Олег, ответ был бы: КНРО

Однажды, посетив магазин канцелярских товаров, Вася купил X карандашей, Y ручек и Z фломастеров. Известно, что цена ручки на 2 рубля больше цены

карандаша и на 7 рублей меньше цены фломастера. Также известно, что стоимость карандаша составляет 3 рубля. Требуется определить общую стоимость покупки.

Входные данные

В единственной строке входного файла INPUT.TXT записаны три натуральных числа X, Y и Z через пробел, каждое из которых не превышает 109.

Выходные данные

В выходной файл OUTPUT.TXT выведите одно целое число – стоимость покупки в рублях.



Вы находитесь на странице вопроса "Декодировать полученное сообщение c=1100011, если известно, что использовался (7, 4) – код", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.