Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

определить сумму чисел ,не превосходящих заданного числа n ,содержащих только нечетные цифры ,СРОООЧНО ПОМОГИТЕ ПОЖААЛУЙСТАА!!

10-11 класс

Fveremyanov 25 янв. 2017 г., 4:54:39 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Farrux
25 янв. 2017 г., 5:46:12 (7 лет назад)

#include <iostream> #include <ctime>//Нужно для генерации n - значных чисел using namespace std;   int getRandVal(int n);//Функция генерирует случайное n-ое число //Функция вернёт массив цифр составляющих число val //переменная n будет содержать число цифр в массиве //флаг bGetArray определяет записывать ли разряды в //массив или лишь ограничиться подсчётом разрядов числа int * splitValue(int val, int &n, bool bGetArray); //Функция проверяет состоит ли число только из нечётных чисел bool isValueConsistOnlyNoOddNumbers(int val);   int main() {     int i;     int m;//Будет содержать число чисел для анализа     int n;//Будет содержать число разрядов для чисел     int sum;//Будет содержать сумму чисел     int cnt;//Будет содержать кол-во n-значных чисел     //состоящих только из нечётных значений     int *arr = NULL;//Указатель на массив с n-значн числами     while(true)     {         system("cls");         cout<<"Enter number values in array : ";cin>>m;         cout<<"Enter n digits in values     : ";cin>>n;         arr = new int[m];         cout<<"Generated array of values\n"

Ответить

Другие вопросы из категории

Ребят, помогитее плиз!

Значок условного перехода на блок-схеме как выглядит?

2 кбайтов это сколько битов

Читайте также

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.

Два натуральных числа называются "дружественными", если каждое из них равно сумме всех делителей другого, за исключением его самого (таковы, например,

числа 220 и 284). Напечатать все пары "дружественных" чисел, не превосходящих заданного натурального числа. (Определить функцию, вычисляющую сумму делителей числа.)сделать в C# (си шарп)Помогите пожалуйста)

помогите решить Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 6. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 6. Пример работы программы: Входные данные Выходные данные 3 12 25 6 18 20.2

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 3. Программа получает на вход количество

чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 3.Количество чисел не превышает 100. Введённые числа не превышают 300.Программа должна вывести одно число – сумму чисел, оканчивающихся на 3.
Паскаль



Вы находитесь на странице вопроса "определить сумму чисел ,не превосходящих заданного числа n ,содержащих только нечетные цифры ,СРОООЧНО ПОМОГИТЕ ПОЖААЛУЙСТАА!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.