Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

составить программу в паскале для поиска простых чисел в числовом промежутке от 1 до 100

10-11 класс

Cool666 20 февр. 2017 г., 23:29:34 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mihalkov01
21 февр. 2017 г., 2:04:06 (7 лет назад)

program abc;
var
  i, j:integer;
  pr:boolean;
begin
  writeln('Простые числа в диапазоне от 1 до 100: ');
  for i := 2 to 100 do
  begin
    pr := true;
    for j := 2 to i div 2 do
      if i mod j = 0 then
      begin
        pr := false;
        break;
      end;
    if pr then
      write(i, ' ');
  end;
  writeln;
end.

Ответить

Другие вопросы из категории

Услуги телефонной сети оплачивают по следующему правилу за разговоры до "а" минут в месяц оплачивают "в" рублей а за разговоры сверхустановленного времени

оплачивают "с" руб в мин .
записать программу вычисляющую плату за пользование телефоном для введенного времени за месяц.

Найдите

наибольшее целое положительное число X, при котором ложно высказывание:

(x(x+2)>54)→(x2>80)

Ребят, помогитее плиз!

Значок условного перехода на блок-схеме как выглядит?

Читайте также

1) Задано положительное число A. Найти сумм всех четных чисел в интервале от 1 до A. Число А может иметь дробную часть.

2) Задано целое положительное число А и В. Найти квадратные корни целых чисел в интервале от А до В. Замечание: A<B



Вы находитесь на странице вопроса "составить программу в паскале для поиска простых чисел в числовом промежутке от 1 до 100", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.