Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1] – данные за первый день, Dat[2] – за второй и т. д.).

10-11 класс

Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования. алг

нач

целтаб Dat[1:10]

цел k, m

Dat[1] := 12

Dat[2] := 15

Dat[3] := 17

Dat[4] := 15

Dat[5] := 14

Dat[6] := 12

Dat[7] := 10

Dat[8] := 13

Dat[9] := 14

Dat[10] := 15

m := 0

нц для k от 1 до 10

если Dat[k]>m то

m := Dat[k]

все

кц

вывод m

кон
DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 12: Dat(2) = 15

Dat(3) = 17: Dat(4) = 15

Dat(5) = 14: Dat(6) = 12

Dat(7) = 10: Dat(8) = 13

Dat(9) = 14:Dat(10) = 15

m = 0

FOR k = 1 TO 10

IF Dat(k)>m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m
Var k, m: integer;

Dat: array[1..10] of integer;

Begin

Dat[1] := 12; Dat[2] := 15;

Dat[3] := 17; Dat[4] := 15;

Dat[5] := 14; Dat[6] := 12;

Dat[7] := 10; Dat[8] := 13;

Dat[9] := 14; Dat[10] := 15;

m := 0;

for k := 1 to 10 do

if Dat[k]>m then

begin

m := Dat[k]

end;

writeln(m);

End.

Yana1477 04 сент. 2016 г., 8:47:25 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
АниЛенга
04 сент. 2016 г., 10:02:07 (7 лет назад)

Программа ищет максимальное значение.
Из 10 приведённых значений максимальное значение равняется 17.
Ответ:17

Ответить

Другие вопросы из категории

помогите срочно задание 2
Сообщение, записанное буквами 64-символьного алфавита, содержит 20

символов. Какой объем информации оно
несет?

Читайте также

Помогите пожалуйста,через пару дней сдавать надо.

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] – заданий сделал первый ученик Dat[2] – второй ученик и т.д.). Определите, что будет напечатано в результате работы следующей программы.

Алгоритмический язык

алг

нач

целтаб Dat[1:12]

цел k, m , month

Dat[1]:=5; Dat[2]:=5

Dat[3]:=6; Dat[4]:=8

Dat[5]:=4; Dat[6]:=5

Dat[7]:=4; Dat[8]:=7

Dat[9]:=4; Dat[10]:=4

Dat[11]:=8

Dat[12]:=7

month := 1; m:= Dat[1]

нц для k от 2 до 12

если Dat[k] <= m то

m:=Dat[k]

все

кц

вывод month

кон

Дан массив температура за ноябрь. Определить:

Сколько дней температура была положительной?
Вывести номера всех дней, когда температура была ниже 5 и выше 18 градусов.
Кол-во дней в месяце и массив температуру ввести с клавиатуры.
В том случае, если таких дней нет, то вывести сообщение об этом.

Дан одномерный массив из 10 элементов. Элементы массива лежат в диапазоне от -20 до 20 и обозначают температуру первой декады (10 дней) марта. Определите

номера дней, когда температура опускалась ниже -10. Напишите программу, которая позволяет найти и вывести номера дней, когда температура опускалась ниже -10.



Вы находитесь на странице вопроса "В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1] – данные за первый день, Dat[2] – за второй и т. д.).", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.