Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Известны данные о среднемесячной температуре за год. Определить,какая была самая высокая температура летом и самая низкая зимой. Нужен код программы в

10-11 класс

паскаль.

Oksana802 07 февр. 2014 г., 9:44:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elenochka145
07 февр. 2014 г., 10:41:13 (10 лет назад)

Program Task;
Const m = 12;
Var a: Array [1..m] of Integer;
i: Integer;

Function Max(a, b: Integer): Integer;
Begin
If a > b Then
Result := a
Else
Result := b;
End;

Function Min(a, b: Integer): Integer;
Begin
If a < b Then
Result := a
Else
Result := b;
End;
Begin
WriteLn('Введите среднемесячные температуры за год (через пробел)');
For i := 1 To m Do
Read(a[i]);
WriteLn('Самая высокая температура летом равна ', Max(Max(a[6], a[7]), a[8]));
WriteLn('Самая низкая температура зимой равна ', Min(Min(a[11], a[12]), a[1]));
ReadLn;
End.

Ответить

Читайте также

скорость чтения учащегося составляет приблизительно 250 символов в минуту. приняв мощность используемого алфавита за 64 ,определите, какой объём

информации в килобайтах получит учащийся, если он будет непрерывно читать в течение 40 минут?

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Дан массив температура за ноябрь. Определить:

Сколько дней температура была положительной?
Вывести номера всех дней, когда температура была ниже 5 и выше 18 градусов.
Кол-во дней в месяце и массив температуру ввести с клавиатуры.
В том случае, если таких дней нет, то вывести сообщение об этом.

Задание звучит : Дана последовательность целых чисел, за которой следует ноль. Определить, число соседств чисел с одинаковыми знаками.

Что нужно изменить в программе, чтобы выполнялось условие задачи.

Program exapmle2;
var x,y,k:integer;
begin
writeln('Эта программа определяет, число соседств чисел с одинаковыми знаками');
write('Введите число:');
read(x);
y:=x;
k:=0;
while y<>0 do
begin
if x*y<0 then inc(k);
if x*y>0 then inc(k);
y:=x;
read(y);
end;
writeln(' Число соседств ',k);
writeln('нажмите Enter для завершения работы программы');
readln;
end.

Задачи на массив в Turbo Pascal

1) Определите ,на сколько отличается рост самого высокого и самого низкого учащегося в классе?
2) результаты переписи населения, которые хранятся в памяти компьютера. Элемент массива -год рождения жителя. Подсчитайте общее число жителей, родившихся раньше 1958 года.
3) С 8 до 20 часов температура воздуха измерялась ежечасно, и результаты измерения заносились в компьютер. Известно, что в течение этого времени температура понижалась. Напишите программу, определяющую, в котором часу была впервые отмечена отрицательная температура



Вы находитесь на странице вопроса "Известны данные о среднемесячной температуре за год. Определить,какая была самая высокая температура летом и самая низкая зимой. Нужен код программы в", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.