Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задание звучит : Дана последовательность целых чисел, за которой следует ноль. Определить, число соседств чисел с одинаковыми знаками.

10-11 класс

Что нужно изменить в программе, чтобы выполнялось условие задачи.

Program exapmle2;
var x,y,k:integer;
begin
writeln('Эта программа определяет, число соседств чисел с одинаковыми знаками');
write('Введите число:');
read(x);
y:=x;
k:=0;
while y<>0 do
begin
if x*y<0 then inc(k);
if x*y>0 then inc(k);
y:=x;
read(y);
end;
writeln(' Число соседств ',k);
writeln('нажмите Enter для завершения работы программы');
readln;
end.

DanilaDanilovdanila 01 июля 2014 г., 23:05:57 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vbutkevich2001
01 июля 2014 г., 23:57:56 (9 лет назад)

Program exapmle2;
var x,y,k:integer;
begin
writeln('Эта программа определяет, число соседств чисел с одинаковыми знаками');
write('Введите число:');
read(x);
y:=x;

 

write('Введите число:'); //добавить эти 2 строки
read(x);


k:=0;
while x<>0 do // поменять у на х
begin
//if x*y<0 then inc(k); убрать эту строку
if x*y>0 then inc(k);
y:=x;
read(x); // изменить у на х
end;
writeln(' Число соседств ',k);
writeln('нажмите Enter для завершения работы программы');
readln;
end.

Ответить

Другие вопросы из категории

Монитор это - ...

1) Устройство для отображения текстовой и графической информации

2) Манипулятор в форме небольшой коробочки, управляющий положением курсора на экране

Какая информация будет меньше всего занимать места на диске?

1. текст длинной в 1 символ,
2.фото размером 10х10 пикселей
3.музыка длинной 10 секунд
4.видео длинной 1 секунда размером 100х100 пикселей

Спасибо за ответ

скорость чтения учащегося составляет приблизительно 250 символов в минуту. приняв мощность используемого алфавита за 64 ,определите, какой объём

информации в килобайтах получит учащийся, если он будет непрерывно читать в течение 40 минут?

Читайте также

Дана непустая последовательность натуральных чисел, за которой следует 0. Составьте программу нахождения суммы чисел этой

последовательности.Запустите программу на выполнение...(ПО ПАСКАЛЮ..)

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .



Вы находитесь на странице вопроса "Задание звучит : Дана последовательность целых чисел, за которой следует ноль. Определить, число соседств чисел с одинаковыми знаками.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.