Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дана последовательность целых чисел, за которой следует ноль. Определить чередуются ли в ней четные и нечетные числа.

10-11 класс

Caza4kovamila 23 янв. 2015 г., 20:14:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alincaw
23 янв. 2015 г., 22:04:12 (9 лет назад)

не очень понятно условие задачи, решил, как понял

 

Program qaf;

uses crt;

var x,y,z:integer;

begin

clrscr;

readln(X);

y:=0;

z:=0;

while x<>0 do begin

if odd(x) then inc(y) else

inc(z);

readln(x);

end;

writeln('кол-во нечётных=',y,'кол-во чётных=',z);

readln;

end.

Ответить

Читайте также

Задание звучит : Дана последовательность целых чисел, за которой следует ноль. Определить, число соседств чисел с одинаковыми знаками.

Что нужно изменить в программе, чтобы выполнялось условие задачи.

Program exapmle2;
var x,y,k:integer;
begin
writeln('Эта программа определяет, число соседств чисел с одинаковыми знаками');
write('Введите число:');
read(x);
y:=x;
k:=0;
while y<>0 do
begin
if x*y<0 then inc(k);
if x*y>0 then inc(k);
y:=x;
read(y);
end;
writeln(' Число соседств ',k);
writeln('нажмите Enter для завершения работы программы');
readln;
end.

Дана непустая последовательность натуральных чисел, за которой следует 0. Составьте программу нахождения суммы чисел этой

последовательности.Запустите программу на выполнение...(ПО ПАСКАЛЮ..)

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .



Вы находитесь на странице вопроса "Дана последовательность целых чисел, за которой следует ноль. Определить чередуются ли в ней четные и нечетные числа.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.