Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано не менее трех различных натуральных чисел, за которыми следует 0. Определить 3 наибольших числа среди них.

10-11 класс

Tanzilabersano 16 янв. 2015 г., 20:09:48 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
PA3BAN
16 янв. 2015 г., 21:41:13 (9 лет назад)

Program msdos_2;
uses crt;
var
  a:array[1..3] of integer; //массив трёх максимальных элементов
  r,max,i,j: integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  r:=1;
  writeln('Введите ненулевое число');
  writeln('(или введите 0 для конца последовательности) ');
{вводим 3 первых элемента}

for i:=1 to 3 do
    begin
      write('Ввод:');  
      readln (r);
      a[i]:=r;
    end;
{сортируем массив из 3-х первых элементов}
  for i:=1 to 2 do
    begin
      max:=a[i];
      for j:=i+1 to 3 do
        if a[j]>max then
           max:=a[j];
      a[j]:=a[i];
      a[i]:=max;
    end;
{Продолжаем ввод и сравниваем текущее число с массивом из 3-х первых}
  while r<>0 do
    begin
      write('Ввод:');  
      readln (r);
      if r>a[1] then
          begin
            a[3]:=a[2];
            a[2]:=a[1];
            a[1]:=r;
          end
        else
          if r>a[2] then
              begin
                a[3]:=a[2];
                a[2]:=r;
              end
            else
              if r>a[3] then
                a[3]:=r;
    end;
{выводим 3 максимальных элемента}

  writeln();
  writeln('Три наибольших элемента массива:');
  for i:=1 to 3 do
    writeln(i,'-й: ',a[i]);
end.

Ответить

Читайте также

Дана непустая последовательность натуральных чисел, за которой следует 0. Составьте программу нахождения суммы чисел этой

последовательности.Запустите программу на выполнение...(ПО ПАСКАЛЮ..)

Задание звучит : Дана последовательность целых чисел, за которой следует ноль. Определить, число соседств чисел с одинаковыми знаками.

Что нужно изменить в программе, чтобы выполнялось условие задачи.

Program exapmle2;
var x,y,k:integer;
begin
writeln('Эта программа определяет, число соседств чисел с одинаковыми знаками');
write('Введите число:');
read(x);
y:=x;
k:=0;
while y<>0 do
begin
if x*y<0 then inc(k);
if x*y>0 then inc(k);
y:=x;
read(y);
end;
writeln(' Число соседств ',k);
writeln('нажмите Enter для завершения работы программы');
readln;
end.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .



Вы находитесь на странице вопроса "Дано не менее трех различных натуральных чисел, за которыми следует 0. Определить 3 наибольших числа среди них.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.