Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите с паскалем

10-11 класс

3. Составить программу, которая бы по последней цифре многозначного числа выдавала бы одно из сообщений:
число не делится ни на 2, ни на 5
число делится только на 2
число делится только на 5
число делится и на 2, и на 5.

89526141770 19 июля 2014 г., 12:19:54 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Va2301
19 июля 2014 г., 13:57:22 (9 лет назад)

var a:string;
b:integer;
begin
readln(a);
b:=strtoint(a[length(a)]);
if (b mod 2 <> 0) and (b mod 5 <> 0) then writeln('число не делится ни на 2, ни на 5');
if (b mod 2 = 0) and (b mod 5 <> 0) then writeln('число делится только на 2');
if (b mod 2 <> 0) and (b mod 5 = 0) then writeln('число делится только на 5');
if (b mod 2 = 0) and (b mod 5 = 0) then writeln('число делится и на 2, и на 5');
end.

Ответить

Другие вопросы из категории

13. Если отрицание стоит над операцией, то первым выполняется:

1). отрицание, затем операция

2). операция затем отрицание

3). операция над переменой

Читайте также

Помогите с паскалем, у меня практика, это очень срочно...

1. Вычислите выражение при заданных константах: A=16.5; b=3.4; x=0.61; S=x^3tg^2(x+b)^2+a/√x+b; Q=bx^2-a/e^a^x-1





2.

Составить программу вычисления значения функции. На экран вывести функцию (записанную на Паскале) вместе с результатом.


у={a+b+cx^2,если 1<=x<2
(a*sin(xb))^2,если 2<=x<3
под корнем |a+bx^2|+c ,если 3<=x<4
a*ln|b+c/2x| ,если 4<=x<5
e^esinx+c^3 ,если 5<=x<6


Пожалуйста...

Помогите пожалуйста.паскаль АВС

Треугольник задан координатами своих вершин.Составить программу вычисления площади треугольника.

Помогите, пожалуйста(Паскаль):

Даны действительные положительные числа x

Помогите с паскалем ABC


Вы находитесь на странице вопроса "Помогите с паскалем", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.