Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

HELP!ЗАДАНИЕ В ПАСКАЛЕ!!!!!!!! код проги рисующей параболу Var g,h:integer; x,y:real; x0,y0,xm,ym,Mx,My:integer; begin

10-11 класс

g:=detect;

InitGraph(g,h,'');
begin

line(0,round(getmaxY/2),GetmaxX,round (GetMaxy/2));
line (round (GetMaxX/2),0,round(GetmaxX/2),GetmaxY);

end;


For xm:=20 to 620 do

Begin

x:=(xm-x0)/Mx;

y:=X*X;

ym:=round(y0-y*My);

PutPixel(xm,ym,15);

End;

Readln;

End.

что означает

Begin

x:=(xm-x0)/Mx;

y:=X*X;

ym:=round(y0-y*My); ? Зачем использовать его в коде?

__________

Mx, My-масштабы соответственно по осям x и y, которые показывают число пикселей в одной физической единице,

x, y- физические координаты точки,

xm, ym- машинные координаты точки,

x0, y0- машинные координаты начала физической системы координат.

89126950030 22 дек. 2016 г., 10:24:58 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Саша5713
22 дек. 2016 г., 11:05:26 (7 лет назад)

Так это у тебя высчитывается пропорциональный коэффициент между положением точки на графике и отображением её на графическом экране. То есть на графике точка параболы с координатами (2;2), а на графическом экране  (220,200).    

Ответить

Другие вопросы из категории

Ребят, помогите с информатикой. Капец как надо...

заполните массив из 8 чисел натуральными числами с клавиатуры найти сумму первых четырех и произведение последних четырех поменять первый и четвертый элемент массива найти среднее арифметическое 3 - 7 вывести все на экран

Читайте также

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

Задача по информатике (Паскаль)

Пожалуйста помогите сделать задание в паскале.







Дана
матрица А(3.3)

1)

Почему на этапе ввода последней ступени (т.е. задали х=5 и вводим 5 ступень) паскаль выкидывает ошибку: "Индекс находился вне границ массива", ведь al[x]

это его последний элемент, разве нет?
Код:

program s1;
var x, i:integer;
al, tl: array of real;
begin
writeln ('Введите количество ступеней ракеты'); read (x);
setlength (al, x);
setlength (tl, x);
for i:=1 to x do begin
writeln ('Введите ускорение ', i, ' ступени'); read (al[i]);
writeln ('Введите время работы ', i, ' ступени'); read (tl[i]);
end;
end.
P.S.: Переписать массив в статический не предлагать, нужен именно переменной длины. Заранее спасибо.



Вы находитесь на странице вопроса "HELP!ЗАДАНИЕ В ПАСКАЛЕ!!!!!!!! код проги рисующей параболу Var g,h:integer; x,y:real; x0,y0,xm,ym,Mx,My:integer; begin", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.