Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан массив из n целых чисел.Выяснить,какое число встречается в массиве чаще-положительное или отрицательное.

10-11 класс

Bokareva91 23 июля 2014 г., 12:40:30 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Okkssana
23 июля 2014 г., 13:17:21 (9 лет назад)

VAR a:array[1..1000] of integer;
n,i,kp,ko:integer;
begin
randomize;
write('Введите количество элементов массива n='); readln(n);
for i:=1 to n do begin a[i]:=random (100)-50; write(a[i],' '); end;
ko:=0; kp:=0;
for i:=1 to n do
if a[i]> 0 then kp:=kp+1 else if a[i]<0 then ko:=ko+1;
if ko>kp then writeln('Чаще встречаются отрицательные числа')
else if ko<kp then writeln('Чаще встречаются положительные числа') else writeln('Количество положительных равно количеству положительных');
end.

Ответить

Другие вопросы из категории

Контрольная помогите срочно !!

Написать программу натурального числа n в квадрате , используя следующую закономерность n в квадрате =1+3+5+7.....+(2n-1)

1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и

вывести список книг, изданных после 2003 года.



2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.

напишите в паскале пжл

Дано натуральное число. Определить какое из цифр встречается в этом числе чаще 0 или 9

Читайте также

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел среди 10 элементов вещественного

массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

Сделайте пожалуйста блок-схему или код в small basic. Дан массив из 20 целых чисел. В массиве хранятся результаты соревнований по спортивной стрельбе.

Один элемент массива соответствует количеству очков, набранных одним участником соревнований, и имеет значение от 0 до 30 включительно. Необходимо разработать программу, которая по данным массива вычисляет максимальное количество очков среди участников соревнований, и количество участников набравшее зачётное количество очков. Зачётное количество очков 18. Гарантируется, что хотя бы один участник соревнований набрал зачётное количество очков.



Вы находитесь на странице вопроса "Дан массив из n целых чисел.Выяснить,какое число встречается в массиве чаще-положительное или отрицательное.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.