Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Составьте программу вычисляющую, сумму квадратов чисел от 1 до n, (n- вводится с клавиатуры) если n-четное, и сумму кубов чисел от 1 до n, если

5-9 класс

n-нечетное. Использовать цикл WHILE

2000310713 06 авг. 2014 г., 0:17:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
CaptainBizarre
06 авг. 2014 г., 1:11:20 (9 лет назад)

program name;
var i,n,x,summa,count:integer;
nechet:boolean;
begin
Writeln('Vvedite n: ');
readln(n);//получаем n
summa:=0;
count:=0;
i:=1;
if(n mod 2 = 1) then nechet := true else nechet := false; //проверяем четное число или нет
while i<n do begin//пока число меньше n
if(nechet) then//если число нечентное
begin
summa:=summa+i*i*i;//прибавляем к сумме куб этого числа
end
else//если число четное
begin
summa:=summa+i*i;//прибавляем квадрат числа
end;
i:=i+1;//прибавляем число на 1
end;
writeln(' summa: ', summa);//выводим сумму
readln();
end.

Ответить

Читайте также

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


Помогите составить программу , вычисляющую сумму квадратов n чётных натуральных чисел

( сейчас прошли циклические алгоритмы, нужна и блок-схема)



Вы находитесь на странице вопроса "Составьте программу вычисляющую, сумму квадратов чисел от 1 до n, (n- вводится с клавиатуры) если n-четное, и сумму кубов чисел от 1 до n, если", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.