Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

1)дано целое число N(больше 0). Найти сумму 1+1/2+1/3.....1/N(вещественное число). Входные данные: ввести целое числоN(1<=n<=20) Выходные

5-9 класс

данные: вывести сумму 1+1/2=1/3+.....1N с точностью до 4 цифр в дробной части.( в паскале)

Natasha2013hora 21 марта 2014 г., 23:07:00 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Andrey890864633
21 марта 2014 г., 23:55:02 (10 лет назад)

var H: real;

   N, i: integer;

begin

   H := 0;

   readln(N);

   for i := 1 to N do

      H := H + 1/i;

   writeln(H:6:4)

end.

Ответить

Читайте также

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

Составить программы в Turbo Pascal. 1)Дано три точки A,B,C на числовой оси.Найти длинну отрезка AC и BC и их сумму. 2)Задано четыре целых числа

a,b,c,d.Выяснить произведение этих чисел больше 300? 3)Дано целое число ,если оно положительное,то прибавить к нему 1,а если отрицательное.то отнять от него 2.Вывести полученое число.

Вариант № 2 1)Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87.

Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

3)Дано целое число а и натуральное (целое неотрицательное) число n. Вычислить а в степени n, используя в программе лишь операцию умножения.

4)Введите последовательность из n целых чисел. Найти наибольшее из всех отрицательных чисел. Вывести его значение и порядковый номер.

5)Вычислите: 99-97+95-93+91-89+....+7-5+3-1.

6)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения (эквивалентны): A OR (B AND C) и (A OR B) AND (A OR C).

1.Дано целое число,лежащее в диапазоне 1-999.Вывести его строку-описание вида "четное двузначное число","нечетное трехзначное число" и т.д.

2.Даны 3 переменные вещественного типа:А,В,С.Если их значения упорядочены по возрастанию,то удвоить их.В противном случае заменить значение каждой переменной на противоположное.Вывести новые значения переменных А,В,С.
3. Даны 3 целых числа,одно из которых отлично от двух других,равных между собой. Определить порядковый номер числа,отличного от остальных.



Вы находитесь на странице вопроса "1)дано целое число N(больше 0). Найти сумму 1+1/2+1/3.....1/N(вещественное число). Входные данные: ввести целое числоN(1<=n<=20) Выходные", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.