Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите составить на языке Pascal программу вычисления заданной функции.

10-11 класс

BlackMeowCat 14 сент. 2014 г., 15:44:26 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
LeonOksana
14 сент. 2014 г., 18:24:24 (9 лет назад)

var
  a, x, y, b: real;

begin
  Write('Введите через пробел значения x,a ->');
  Readln(x, a);
  b := abs(x - 2.7);
  if b = 0 then Writeln('Ноль в качестве аргумента логарифма недопустим')
  else begin
    b := sqrt(ln(b));
    if b = 0 then Writeln('Деление на ноль при попытке вычислить выражение')
    else begin
      b := (x - sqr(a)) / b;
      if b > 0 then b := exp(1 / 5 * ln(b))
      else if b = 0 then b := 0
      else b := -exp(1 / 5 * ln(-b));
      Writeln('Значение функции ', b)
    end
  end
end.

Тестовое решение:
Введите через пробел значения x,a ->5.1 1.3
Значение функции 1.29517010518691

Ответить

Другие вопросы из категории

С какой скоростью осуществляется передача информации объёмом 1428 Кб,

если передача длится 5 мин. 57 сек.?

1. Помогите исправить ошибки и нарисовать блок-схему. Задание: дана матрица целых чисел размером

4х4. Поменять местами первый и последний элемент массива х.

Листингпрограммы:

Помогите решить школьную задачу на паскале

(Халявные баллы)

1. Определите

значение переменной S после выполнения операторов:

Читайте также

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

Написать программу на языке Паскаль для вычисления значений функции y (см. для своего варианта) на интервале [a,b] с шагом h. Значения a,b и h ввести с

клавиатуры. На экран вывести результат вычислений в виде таблицы. 1 Блок-схема алгоритма программы, выполненная с использованием графических средств редактора WORD; 2 Текст программы; 3 Результаты выполнения (копия экрана). (3x+2)^2- sqrt3x/(3x)^2 a 5;b 7; h 0,1

Составьте блок-схему и программу

на языке Pascal для вычисления длин высот треугольника, у которого длины
сторон a, b, c (a, b,

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.



Вы находитесь на странице вопроса "Помогите составить на языке Pascal программу вычисления заданной функции.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.