Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

В соревнованиях по прыжкам в длину участвуют 25 спортсменов, с клавиаиуры ввести номер спортсмена и его результат ( номер спортсмена не связан с

5-9 класс

очередностью). Написать программу, которая выводит на экран номер и результат худшего и лучшего спортсменов. все это как то связанно с оператором повтора FOR

Patrona33l 19 февр. 2017 г., 16:08:32 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Wikos17
19 февр. 2017 г., 17:11:26 (7 лет назад)

var a,b:array[1..25] of integer;
i,min,max:integer;
begin
max:=1;
min:=1;
for i:=1 to 25 do begin
read(a[i]);
read(b[i]);
if a[i]>a[max] then max:=i;
if a[i]<a[min] then min:=i;
end;
writeln('Лучший - ',a[max],' длина - ',b[max]);
writeln('Худший - ',a[min],' длина - ',b[min]);
end.

Ответить

Другие вопросы из категории

18. Предложены команды:

1. создать файл gramota.doc;

2. создать каталог NEW;

3. создать каталог SCHOOL;

c) стирается на ""жестком диске'";

d)стирается на магнитном диске;

e) стирается на компакт-диске.

d)файл, защищенный от несанкционированного доступа;

e) файл, зараженный компьютерным вирусом.

4. войти в созданный каталог;

5. сделать диск С: текущим.

Расположите пронумерованные команды так, чтобы был получен алгоритм, с помощью которого на пустой дискете создается файл с полным именем C:\SCHOOLY\NEW\gramota.doc

a) 5; 2; 3; 1;

b) 5; 1; 3; 4; 2;

c) 5;3:4;2;4; 1;

d) 5; 1: 2; 3; 4;

e) 1;3;2;5.

1.9. «... памяти означает, что любая информация заносится в память и извлекается из нее по...». Вместо многоточий вставить соответствующие слова:

a) дискретность; адресам; d) адресуемость; байтам;

b) адресуемость; значениям; е) адресуемость; адресам.

c) дискретность; битам;

20. В системное ПО ходят:

a) языки программирования:

b) операционные системы;

c) электронные таблицы;

d) совокупность всех программ, установленных на компьютере:

e) графические редакторы

Читайте также

На международных соревнованиях по прыжкам в воду первые пять мест заняли спортсмены из Германии, Италии, Китая, России и Украины. Еще до начала соревновани

й эксперты высказали свои предположения об итогах:
Первое место займет спортсмен из Китая, а спортсмен из Украины будет третьим.
Украина будет на последнем месте, а Германия - на предпоследнем
Германия точно будет четвертой, а первое место займет Китай.
россия будет первой, а Италия - на втором месте.
Нет, Италия будет пятой, а победит Германия.
По окончании соревнований выяснилось, что каждый эксперт был прав только в одном утверждении. Какие места в соревновании заняли участники?

Выполняется в Microsoft Office Excel. Помогите пожалуйста. спортсменов-многоборцев принимают участие в соревнованиях по 5 видам спорта. По каждому виду

спорта спортсмен набирает определенное количество очков по десятибалльной шкале. Все исходные данные (фамилии спортсменов, виды спорта и баллы за них) задаются произвольным образом на ваше усмотрение. Спортсмену присваивается звание мастера, если он набрал в сумме не менее 45 очков, если не менее 30 очков – кандидат в мастера спорта, а если менее 30 очков, то претендент.

РЕШИТЬ ЗАДАЧУ С ПОМОЩЬЮ СХЕМЫ СОСТАВА. В школе проходят спортивные соревнования по баскетболу и волейболу. Некоторые из них участники, а остальные

зрители. На соревнованиях по волейболу было 28 мальчиков. Ни одна из девочек не пришла смотреть на баскетбол. Всего на соревнованиях по баскетболу было 54 мальчика, из них 38 не участники. Среди зрителей 48 мальчиков и 33 девочки. Участников баскетболистов 50 человек. Разберитесь, кто есть кто?

составить программу Паскаль к задаче: 1)в 200 граммах воды растворили 25 грамм поваренной соли. найдите массовую долю соли в растворе?

2)вычислить площадь и периметр прямоугольного треугольника по заданным длинам двух катетов а и b

1.Для кодирования сообщений решено использовать последовательности разной длины, состоящие из знаков «+» и «-». Сколько различных сообщений можно

закодировать, используя в каждом из них не менее 3-х и не более 7 знаков?
2.В велокроссе участвуют 987 спортсменов. Специальное устройство регистрирует прохождение каждым из участников промежуточного финиша, записывая его номер с использованием минимально возможного количества бит, одинакового для каждого спортсмена. Каков информационный объем сообщения, записанного устройством, после того как промежуточный финиш прошли 60 велосипедистов?
3.Метеорологическая станция ведет наблюдение за температурой воздуха. Результатом измерения является целое число, принимающее значение от –20 градусов до +12 градусов включительно, которое записывается при помощи минимально возможного количества бит.
Станция сделала 120 измерений. Каков информационный объем результатов наблюдений?
4.Метеорологическая станция ведет наблюдение за температурой воды.
Результатом измерения является целое число, принимающее значение от +1 градуса до +32 градусов включительно, которое записывается при помощи минимально возможного количества бит. Станция сделала 160 измерений. Каков информационный объем результатов наблюдений?



Вы находитесь на странице вопроса "В соревнованиях по прыжкам в длину участвуют 25 спортсменов, с клавиаиуры ввести номер спортсмена и его результат ( номер спортсмена не связан с", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.